WOOHOO found the issue.

On FreeBSD if you are going to do a custom compile, make sure you add
'--prefix=/usr/local i386-portbld-freebsd5.1' to your ./configure
command. (this is not documented and I only knew by looking at the ports
version closely)

Using the following command worked!

./configure --enable-valias=y --enable-mysql-logging=y
--enable-auth-logging=y --enable-default-domain=bwlogic.com
--enable-domain-quotas=y --enable-mysql=y --enable-many-domains=y
[EMAIL PROTECTED] --enable-qmaildir=/var/qmail
--enable-defaultquota=52428800 --enable-logging=p
--enable-roaming-users=y --enable-relay-clear-minutes=30
--enable-clear-passwd=y --prefix=/usr/local i386-portbld-freebsd5.1

As you can see I am using MySQL and the default ports distribution uses
cdb, this is why doing a build straight from the ports tree fixed my
clearopensmtp error message, however I lost all my user accounts as
these are in MySQL. Using the ports version with the above configure
command fixed all my issues.

Thanks all for your input, it help a ton :D


-----Original Message-----
From: Michael Bowe [mailto:[EMAIL PROTECTED] 
Sent: Tuesday, November 11, 2003 3:00 PM
Subject: Re: [vchkpw] Interesting clearopensmtp and tcpserver issue

----- Original Message ----- 
From: "Jason Lavigne" <[EMAIL PROTECTED]>
Sent: Wednesday, November 12, 2003 2:35 AM
Subject: [vchkpw] Interesting clearopensmtp and tcpserver issue

> Hello all,
> I have gone through the archives and have gone through all the posts
> that looked like my error, however I am still stuck and I have not
> any changes at all. Here is what I have,
> I get this error each time I run
> tcpserver: fatal: unable to figure out port number for
> /etc/tcp.smtptmp.3517 (<- the number changes each time I run)

Generally when using roaming-users, you need to put all the tcp.smtp.*
in ~vpopmail/etc rather than /etc

This is because the vpopmail user needs write permission on the
and tcp.smtp.tmp files and typically the /etc dir wont allow that.

Just linking the files to the vpopmail/etc dir isnt sufficient, as
needs to create temp files etc, and in your case these will be created
/etc which I guess will fail.


Reply via email to