If I didn't myself clear. When using SMTP AUTH, I run:

/var/qmail-in/bin/qmail-smtpd \
/var/vpopmail/bin/vchkpw /bin/true 2>&1

And even so, I get the error message:
-ERR this user has no $HOME/Maildir

I changed the authtype var, so it would be always SMTP,
but it didn't solve my problem.


Hélio Rubens Kamogawa
Central Server
+55 41 324-1993

On Friday 19 December 2003 18:27, Casey Zacek wrote:
> Tom Collins wrote (at Fri, Dec 19, 2003 at 12:57:21PM -0700):
> > On Friday, December 19, 2003, at 10:28  AM, H?lio Rubens Kamogawa 
> > >I have tried to comment the code below the commentary but even so
> > > when I
> > >try to authenticate, vchkpw returns a error saying:
> > >-ERR this user has no $HOME/Maildir
> >
> > That's not a vpopmail error, that's a qmail-pop3d error.  It's
> > quite normal for a POP3 connection to fail if the user's Maildir
> > does not exist -- there isn't much you can do without one.
> >
> > When doing SMTP AUTH though, there isn't any reason why it should
> > be necessary.
> I think the root of the problem here is that he's running qmail-pop3d
> and trying to use that for SMTP AUTH somehow.
> There's no reason to run POP3 on an SMTP only machine.
> Of course vchkpw will look for a user's Maildir if it's
> authenticating for POP3.  Try using qmail-smtpd with a patch for SMTP


Reply via email to