Ive got the same problem, I just tried your changes but I still get the

tcprules: fatal: unable to parse this line: ::ffff:IPHERE:

error. Courier has been compiled against the rc1. Tom mentioned in a
reply to the first post about deleting the opensmtp file... where and
what file is that

-----Original Message-----
From: Alejandro Aguilar Sierra [mailto:[EMAIL PROTECTED] 
Sent: Monday, 12 January 2004 5:31 a.m.
Subject: [vchkpw] More on clearopensmtp


In a recent post, Tom Collins wrote that the bug causing IPs with the
"::ffff:" prefix in open-smtp had been fixed in 5.4-rc1. However, I got
the same problem with 5.4.-rc1 and courier-imap-2.2.1. I fixed it after
this hack to vpopmail.c:

--- vpopmail.c.orig     Sun Jan 11 01:32:39 2004
+++ vpopmail.c  Sun Jan 11 01:33:19 2004
@@ -3054,7 +3054,8 @@
   char *p;

   ipenv = getenv("TCPREMOTEIP");
-  if ((ipenv == NULL) || (strlen(ipenv) > sizeof(ipaddr))) return
+/*  if ((ipenv == NULL) || (strlen(ipenv) > sizeof(ipaddr))) return
ipenv; */
+  if (ipenv == NULL) return ipenv;

   strcpy (ipbuf, ipenv);
   ipaddr = ipbuf;
---------------------- END OF PATCH  ------------------

The commented condition (strlen(ipenv) > sizeof(ipaddr)) is true for
::ffff:IPs, so they are never filtered.

Then it was fixed or not? Did I made anything wrong?

Best regards.

Alejandro Aguilar Sierra

Reply via email to