Brian Lanier wrote:

I ran into this problem before and always figured it was a problem on the
handoff between qmail and maildrop. If I remember correctly the $EXT and
$HOST are qmail environment variables, someone can correct me if I am wrong.
In my case the $EXT variable was not being set. We initially had a clumsy
awk command to manually set the line. Once we upgraded Maildrop the problem
went away.  To test try spitting the values to a log file with something
like the following in your maildrop filter:
logfile "/usr/local/vpopmail/maildroplog"
log "EXT is $EXT"
log "HOST is $HOST"
log "VHOME is $VHOME"

Of course put the VHOME log line after the line where you set it...

I am currently using maildrop 1.6.3. As far as I know in this configuration,
vpopmail doesn't have much to do with these variables other than trying to
use them in the VHOME line.

Hope this helps in some way. I never could find any info on this and just
worked around until one day it started working after an upgrade.

Thanks, this worked out great. All of the variable are being defined correctly.

Reply via email to