All:

Many seem to achieve smtp-auth, but I haven't yet, and the natives are getting restless. Vpopmail itself has been running successfully for multiple domains for several months.

I've tried serveral configurations with vpopmail, always followed by rebuilding "ucspi-tcp-0.88" because of a library file reference I read. Some configs used the CDB file in its "etc" directory, and others tried mysql's "lastauth" and "relay" tables. The CDB file seems to never be updated, and the "lastauth" table had either "0.0.0.0" or just a blank "" in the "remote_ip" column, but the "timestamp" column was being updated. The "relay" table never appeared to have any records.

I have used pop3 through xinetd and courier-imap with the above results being consistant. Browsing the code, the web, and these archives lead me to think that the "TCPREMOTEIP" enviroment variable isn't being filled, but I couldn't find any specific answers.

Latest vpopmail config:
./configure --enable-mysql=y --enable-mysql-logging=y --enable-valias=y --enable-roaming-users=y \ --enable-relay-clear-minutes=120 --enable-mysql-limits=y --enable-many-domains=n --enable-logging=e \ --enable-tcpserver-file=/home/vpopmail/etc/tcp.smtp --enable-tcprules-prog=/usr/local/bin/tcprules


Pointers, ideas, and / or solid clues would be greatly appreciated.
Thom Campbell




Reply via email to