A few more details on our problem converting a vpopmail 5.4.0rc1 cdb system to vpopmail 5.4.0 using mysql.

We built a brand new server running Bill's Toaster with vpopmail 5.4.0 with mysql and qmailadmin 1.2.0. Everything worked great mysql tables were working, mail was properly recieved and put in the rights places, we could pop in and get mail, we could send mail, etc. Qmailadmin was working just great with mysql.

Then we tried to transfer over our 500 virtual domains and 2500 mail accounts. We tar-zipped the /home/vpopmail/domains directory and expanded it on the new server. We transferred over /var/qmail/control/assign and cdb and /var/qmail/control rcpthosts, morercpthosts, morercpthosts.cdb and virtualdomains.

The we ran ./vconvert which seemed to properly convert the vpasswd files into the mysql tables.

However, at this point we can send email to the server and it gets put into the correct maildir location (and chkuser.mysql.tdma patch is working), we can use 'vadddomain' to add domains and they get added to the mysql tables but 'vdominfo' does not work and the pop server won't let us in to pick up email.

Any ideas how we could have screwed up this conversion? Were we supposed to delete the vpasswd files after converting to mysql? We are absolutely sure vpopmail was compiled with mysql support since that was working previously.

Any advice would be appreciated.

Best Regards,

Jeff Koch

Reply via email to