hello,

i've tried the qmail-smtpd-auth-043_tgz.bin patch but the result is always the same:

454 oops, unable to write pipe and I can't auth (#4.3.0)

#!/bin/sh
VPOPUID=`id -u vpopmail`
VPOPGID=`id -g vpopmail`
LOCAL=`XXXX`
MAXSMTPD=`head -1 /var/qmail/control/concurrencyincoming`
if [ -z "$VPOPUID" -o -z "$VPOPGID" -o -z "$MAXSMTPD" ]; then
    echo QMAILDUID, NOFILESGID or MAXSMTPD is unset in
    echo /var/qmail/supervise/qmail-smtpd/run
    exit 1
fi

exec /usr/local/bin/softlimit -m 3000000 /usr/local/bin/tcpserver -v -R -l "$LOCAL"  -x /etc/tcp.smtp.cdb -c "$MAXSMTPD" -u "$VPOPUID" -g "$VPOPGID" 0 smtp /var/qmail/bin/qmail-smtpd "$LOCAL" /var/vpopmail/bin/vchkpw /bin/true 2>&1

any ideas?

thanks....signo



Erwin Hoffmann wrote:
Hi,

At 16:29 22.04.04 +0200, signo wrote:
  
   hello i've a problem with smtp auth

when i try to send an email i have always the message:
454 oops, unable to write pipe and I can't auth (#4.3.0)

SW:
qmail: 1.3
smtp-auth: qmail-smtpd-auth-0.31

telnet on port 25

Escape character is '^]'.
ehlo
220  -=NO UNSOLICITED BULK E-MAIL=- ESMTP
250- -=NO UNSOLICITED BULK E-MAIL=-
250-AUTH LOGIN CRAM-MD5 PLAIN
250-AUTH=LOGIN CRAM-MD5 PLAIN
250-PIPELINING
250 8BITMIME
auth login
334 VXNlcm5hbWU6
dGVzdEB0ZXN0LmNo
334 UGFzc3dvcmQ6
dGVzdHBhc3M=
454 oops, unable to write pipe and I can't auth (#4.3.0)
auth plain
334 
AHRlc3RAdGVzdC5jaAB0ZXN0cGFzcw==
454 oops, unable to write pipe and I can't auth (#4.3.0)
auth CRAM-MD5
334 PDE0MTg5LjEwODI2Mzg5MjFAL2Jpbi9jaGVja3Zwdz4=
dGVzdEB0ZXN0LmNoIDRlNTE5YTIzZGQzNDBmZjJlMDRjMjkwMjFkODY1ZDNi
454 oops, unable to write pipe and I can't auth (#4.3.0)


qmail-smtp/run script:

#!/bin/sh
QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`
MAXSMTPD=`head -1 /var/qmail/control/concurrencyincoming`
if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" ]; then
    echo QMAILDUID, NOFILESGID orMAXSMTPD is unset in
    echo /var/qmail/supervise/qmail-smtpd/run
    exit 1
fi
    
&1 
      
can you help me?
    

Please read: http://www.fehcom.de/qmail/smtpauth.html

If you contine to use the old SMTP Auth patch, you have to include your
hostname in the call of the PAM.

regards.
--eh.

Dr. Erwin Hoffmann | FEHCom | http://www.fehcom.de/
Wiener Weg 8, 50858 Cologne | T: +49 221 484 4923 | F: ...24

  

Reply via email to