Hello Sebastien,

On Saturday, May 1, 2004 at 6:02:00 PM you wrote (at least in part):

>>>I tried many configurations and it appears that it's the vchkpw that
>>>adds my email adress to my IP when I send a mail.

>>I wouldn't know why and how vchkpw would or could do this.

> First of all I tried with or without vpopmail and without vpopmail I did
> not get that strange line.

How exactly did you try "without" vpopmail? What changes have been
done, what exactly was different from "with vpopmail" trial?

> Obelix:/var/qmail# cat /var/qmail/supervise/qmail-smtpd/run
> #!/bin/sh
> exec /usr/local/bin/tcpserver -H -p -R -x 
> /home/vpopmail/etc/tcp.smtp.cdb -u98 -g98 -v -c100 0 smtp rblsmtpd -r
> relays.ordb.org /var/qmail/bin/qmail-smtpd /home/vpopmail/bin/vchkpw
> /usr/bin/true 2>&1

As I expected I don't see anything that would make qmail-smtpd append
'@<IP-Address>' just because 'vchkpw' is present. 'vchkpw' can't
modify anything within qmail-smtpd's memory area and qmail-smtpd does
not fetch anything 'vchkpw' could 'pass back'. It only has an eye open
if vchkpw exits '0' or not. So I'm still convinced it is not vpopmail
that is the culprit, of course unless you've done heavy modifications
on vpopmail or qmail or have another setup not shown yet.
Best regards
Peter Palmreuther

If you're happy and you know it clunk your chains.

Reply via email to