Am Sonntag, 23. Mai 2004 21:28 schrieb blist:

First of all: I have the same problem - also on Dual-Opteron machines.
I also have been in contact with blist and X-ISTENCE...

> Ok,  after the huge number of irrevlent replies to my last thread I am
> attempting to post an update on my SMTP Auth problem.  I have tried just
> most smtp patchs, the on  in the contrib dir of vpopmail and
>  I
> have included captures of below.

As far as I found out, all smtp-auth-patches are based on Krzysztof 
Dabrowski's auth-patch (
Some are improved, some are mixed with other features...

> Both patches apply without error and compile/install fine.  I am running
> a Dual AMD Opteron system with suse 64 bit.  I have had other people
> look at this situation and there are no solutions.  I can only assume
> the patch has a problem with 64bit systems.  Here is an example of login
> and error and run file:
I found out, that it doesn't matter what other patches are applied. I got the 
same error when using a vanilla qmail with only the auth-patch and the 
errno-patch applied.
I tried to compile while editing conf-cc and adding there -m32 (for 32-bit), 
but I got errors with this.
When I added -m64, it compiled, but I got the same result at the end => auth 
doesn't work.

When running the following:

exec softlimit -m 50000000 tcpserver -vR -l $Server-FQDN -c 1000 -u 89 -g 89 0 
25 /usr/local/bin/recordio sh -c '/var/qmail/bin/qmail-smtpd 
$Server-FQDN /var/vpopmail/bin/vchkpw /usr/bin/true 2>&1'

I get:

tcpserver: status: 0/1000
tcpserver: status: 1/1000
tcpserver: pid 23227 from $Client-IP
tcpserver: ok 23227 $Server-FQDN:$Server-IP:25 $Client-FQDN:$Client-IP::4024
 3227 > 220 $Server-FQDN ESMTP
 3227 < EHLO $Client-Name
 3227 > 250-$Server-FQDN
 3227 > 250-PIPELINING
 3227 > 250 8BITMIME
 3227 < AUTH LOGIN
 3227 > 334 VXNlcm5hbWU6
 3227 < dGVzdEB0ZXN0LmNvbQ==
 3227 > 334 UGFzc3dvcmQ6
 3227 < dGVzdA==
 3227 > 454 oops, problem with child and I can't auth (#4.3.0)
23227 < [EOF]
tcpserver: end 23227 status 256
tcpserver: status: 0/1000
23227 > [EOF]

All Phrases with "$" are "masked" since there are some people on this list, 
which should not know which one is affected.

It also doen't make any change, if I comment the ability of CRAM-MD5 out in 
the source of the patch.

> If you've read this far, thanks!.  Drop me an e-mail if you have any
> other suggestions.  Thanks!
I'll start a post at the qmail-list and try to get in contact with Krzysztof 
Dabrowski and Erwin Hoffmann (since he seems to have experience and speaks 
the same language than I do, it would be a bit easier).

If somebody would be able and willing to have a look at this patch there would 
surely be some people very pleased.
If somebody wants to try but hasn't 64-bit-hardware, I can provide access to 
my machine since it isn't productive (badly).

As blist already wrote, any suggestions would be apreciated. Since there is 
more than one who would be glad about a solution, please post answers to the 



Reply via email to