Hi Tom,

On Sun, 2004-05-30 at 10:38, Tom Collins wrote:
> It sounds like the vpopmail code in Courier-IMAP doesn't correctly 
> handle default domains.  I know that Michael Bowe did a lot of work on 
> that code recently -- are you using the latest release of Courier-IMAP?

Not the latest, but version 3.0.4 .  This was copiled from source.  I
have setup the same version of courier from RPM using the SRPMS at
<http://www.qmailtoaster.com>, on a test box, and Courier-IMAP is
logging users in using the default domain.

> If you're running MySQL, then I assume it isn't a permissions issue, 
> since Courier wouldn't be able to read the vpopmail.mysql file.

I am running MySQL on the backend.  I think you are meaning that
Courier-IMAP does not read the 'vpopmail.mysql' file; is that correct? 
Regardless, I just made it world-readble, and tried logging in:

[EMAIL PROTECTED] root]# telnet localhost 143
trying 127.0.0.1...
connected to van-srv41 [127.0.0.1]
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE
THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION
STARTTLS] Courier-IMAP ready. Copyright 1998-2004 Double Precision,
Inc.  See COPYING for distribution information.
A01 LOGIN alan SeEeCcRrEeTt
A01 NO Login failed.
Connection closed by foreign host.

(I rather suspected that wouldn;t work, but it was worth a try).

> If not, make sure that ~vpopmail/etc/defaultdomain is world-readable, 
> that could be part of the problem.  Keep in mind that ~vpopmail/etc/ 
> needs to be readable by the user that Courier-IMAP runs as.

[EMAIL PROTECTED] root]# ls -l ~vpopmail/etc
total 36
-rw-r--r--    1 vpopmail vchkpw         12 May 30 15:53 defaultdomain
-rw-r--r--    1 root     root           25 May 28 07:53 inc_deps
-rw-r--r--    1 root     root           77 May 28 07:53 lib_deps
-rw-r--r--    1 vpopmail vchkpw         26 May 28 07:48 tcp.smtp
-rw-r--r--    1 vpopmail vchkpw      10580 May 30 15:41 tcp.smtp.cdb
-rw-r--r--    1 vpopmail vchkpw       1107 May 28 07:53 vlimits.default
-rw-r--r--    1 vpopmail vchkpw         42 May 28 07:38 vpopmail.mysql

I am suspecting there is something (unrelated) to this server, because I
have also tried recompiling Courier-IMAP, but it gets to a certain point
then hangs during the configure stage (and it takes a couple minutes to
get the full login prompt). This obviously is not your issue, but it's
just odd.

Anyway, any other ideas you may have would be greatly appreciated.

Sincerely,

Alan Murrell


Reply via email to