I have a really strange problem with vpopmail and smtp. I'm using qmail
and vpopmail together and for pop3 and imap4 it works perfectly. However,
with SMTP AUTH it did work well for some time but doesn't do so any more.
As I didn't realize the problem at once, I actually can't say what exactly
has changed on the system since it worked last. I'm running Gentoo Linux
and there was at least one "emerge -u world" since it worked. I'm using

So here's what happens:
My client gives me an error but there's no error message from the server.
If I look into the log files I find two interesting lines.

Jul 14 12:23:27 myserver vpopmail[13453]: vchkpw-smtp: vpopmail user not
found [EMAIL PROTECTED]: Jul 14
12:23:27 myserver vpopmail[13453]: vchkpw: can't write MySQL logs

I've found out that if I change the permissions of /etc/vpopmail.conf to
world-readability, I don't get the second line and the message is also
written to my vlog-table. I guess it's only a subsequent error which I
wouldn't get if the first one wasn't there. The first error message I
don't understand at all because the user is valid. The same user can fetch
mail without any problems.
Can anybody tell me what is happening here? Is it a problem with
permissions? If yes, permissions of what file? 


    Die Heiden, die um euch her übriggeblieben sind, sollen erfahren,
    dass ich der Herr bin, der da baut, was niedergerissen  ist,  und
    pflanzt, was verheert war.
    Hesekiel 36,36
    "/Paulus  schreibt:/ Wir sind Gottes Mitarbeiter; ihr seid Gottes
    Ackerfeld und Gottes Bau."
    1.Korinther 3,9

Reply via email to