Fred Colclough writes:

I'm trying to implement 'vpopmail roaming users'.

The docs say to "store the tcp.smtp files in ~vpopmail/etc".

I've tried doing so...& updating all the qmail control/run files I could find, but it 'breaks' the svr (smtp errors, no mail in/out).

Here's what I've done:

1. Physical move:
cp /etc/tcp* ~vpopmail/etc
cd ~vpopmail/etc
chown vpopmail.vchkpw tcp*
(wasn't sure who should own 'em... I tried root.root also)

2. Modify qmail files:
/var/qmail/supervise/qmail-smtpd/run : changed path:

exec /usr/local/bin/softlimit -m 4000000 \
/usr/local/bin/tcpserver \
-H -l \
-v -x ~vpopmail/etc/tcp.smtp.cdb \
-c 20 -R -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp \
/usr/local/bin/rblsmtpd -b -C \

/var/qmail/bin/qmailctl : changed in multiple places from:
/etc/tcp... --> ~vpopmail/etc/tcp...

3. qmailctl cdb (just to force a new build in the new folder)

So what did I miss?? As I said, when I make these changes, it 'breaks'. No smtp.



and this is an "I'm not quite sure" answer...but-

What if you give the directory location as an absolute /home/vpopmail...
instead of the "virtual" location ~vpopmail...?
My setup has the path spelled out, and it "Just Works".

Reply via email to