Dave Goodrich wrote:

Dave Goodrich wrote:

Also of note, I can see each user who is being re-prompted, /var/log/maillog shows these on each cluster machine.


Oct 6 11:40:17 ecluster1 vpopmail[1748]: vchkpw-pop3: vpopmail user not found [EMAIL PROTECTED]:68.254.88.126
Oct 6 11:40:19 ecluster1 vpopmail[1758]: vchkpw-pop3: vpopmail user not found [EMAIL PROTECTED]:12.166.28.75
Oct 6 11:41:35 ecluster1 vpopmail[2269]: vchkpw-pop3: vpopmail user not found [EMAIL PROTECTED]:68.251.147.126
Oct 6 11:42:36 ecluster1 vpopmail[2637]: vchkpw-pop3: vpopmail user not found [EMAIL PROTECTED]:68.251.147.126


Each of these users exist, the next attempt they got in.

DAve


Chris Ess wrote:

Dave Goodrich wrote:

Since we changed to use mysql auth I have been getting complaints from
users having to enter their password more than once. This is not
consistant, it doesn't happen every time. It seems most prevelent for
users of Eudora or old Outlook Express. Outlook, Netscape Mail, and
Thunderbird do not seem to be having a problem.


Correction, Outlook Express is working, Outlook is not.


What are they using as their login ID?   I use the email address with a
'%' rather than a '@'. (For instance, if the email address I was sending
was a real user, I would use inter7%cae.tokimi.net )


I believe it works both ways, but I am certain all the techs setup the users with %, I can ask the support staff.


All users experiencing this issue are using % in their login.


My MySQL db is on another server dedicated to serving MySQL connections
to vpopmail and spamc. Plenty of resources, queries per second is only
4.3, threads 11, I have a dual Sparc Enterprize 450 with 2gb of ram.
100mb duplex ether between the mailservers and the db that is used for
nothing but the mysql connection and NFS to the maildirs. I have my
key_buffer=128M and my table_cache=128. Top says I am at a whopping load
of .8.
I just finished upgrading to to 5.4.6 and the problem remains. I've
googled and searched the maillist, anyone have a clue?


"User doesn't exist" sounds like it might be caused by a communication
issue between vchkpw and MySQL.  I'm not 100% sure.  I have never
experienced this issue myself.


This is what I believe as well, which is why I upgraded to 5.4.6. I am looking into possible MySQL issues though I don't think resources is a problem.


I have been working with the MySQL host, upped my my.cnf to the following, no change in the problem.
# The MySQL server
[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
set-variable = key_buffer=256M
set-variable = max_allowed_packet=16M
set-variable = table_cache=256
set-variable = sort_buffer=1M
set-variable = record_buffer=1M
set-variable = myisam_sort_buffer_size=64M
set-variable = thread_cache=4
set-variable = connect_timeout=15
set-variable = back_log=50
set-variable = max_connections=500


# Try number of CPU's*2 for thread_concurrency
# we have 2 CPUs on the Sun 450
set-variable    = thread_concurrency=4
server-id       = 1

I am seeing a lot of aborted connects. This is the result of running just 20 minutes after flushing the stats. I will see 2500+ by tomorrow easily.

# mysqladmin -uroot -p extended-status
+--------------------------+---------+
| Variable_name            | Value   |
+--------------------------+---------+
| Aborted_clients          | 0       |
| Aborted_connects         | 106     | <------------------
| Bytes_received           | 4456034 |
| Bytes_sent               | 6960856 |


I have changed the timeout value in auth.c from 2 to 4, ran make;make install-strip on all the clusters to see if that makes a difference.


I also have a question in to the MySQL forums on this issue.

This is becoming a show stopper for me. If I can't get clients to reliably connect when they pop mail, I will have to find another solution before I install my new mail clusters. I like the concept of having MySQL on another server and all my eclusters using the same db, I really don't want to run local copies of MySQL. Got that great big Sun 450, I want to use it!

I am open for any experiment, test, debug process, chicken bones, incense, palm reading. Just gotta make it work.

Thanks,

DAve





-- Systems Administrator http://www.tls.net Get rid of Unwanted Emails...get TLS Spam Blocker!



Reply via email to