On Fri, 29 Oct 2004, Cream[DONut] wrote:

from my personal experience:
never NEVER EVER run vconvert (unless you are absolutely sure you want to conver t a domain, and then only ONCE, using the correct command the first time to accomplish your task).

I haven't even touched vconvert, nor do I think I need to, but I'll stay away from it. :)


C

and then delete vconvert when your system is ready to be used.

why? i've personally experienced what its like to lose logins for several mysql domains thanks to me forgetting to never run vconvert. (yea been slapping my self a couple of times with a couple of years bethween).

(for the record if anyone should google to this post for the solution:
back up the mysql vpopmail database,
then convert the domains back to mysql
then restore the backup of the mysql database)

disclaimer: this might have been fixed long ago, since i have had it deleted on my system for 2 years.
Charles Sprickman wrote:


Hi,

After running through the same upgrade on a test box, I tried it on the production box today. pop and imap continued working fine, but smtp-auth seemed to be borked (probably because I had not yet recompiled it).

So then I started poking around with the "v*" commands. They all spit out some nasty mysql errors:

[EMAIL PROTECTED]/usr/local/src/toaster/vpopmail]# ~vpopmail/bin/vuserinfo chip
vmysql: sql error[3]: Commands out of sync;  You can't run this command now
no such user [EMAIL PROTECTED]
Segmentation fault

[EMAIL PROTECTED]/usr/local/src/toaster/vpopmail]# vdominfo blah.net
domain: blah.net
uid: 90
gid: 90
dir: /home/vpopmail/domains/blah.net
vmysql: error creating table 'dir_control': Table 'dir_control' already exists
users: 0
Segmentation fault (core dumped)


Putting my old binaries/libs back brought everything back in order. The test box is running the same version of mysql client libs and the same version of vpopmail. What might be causing this?

The only info I found was this mysql doc:

http://dev.mysql.com/doc/mysql/en/Commands_out_of_sync.html

The "vmysql: error creating table 'dir_control': Table 'dir_control' already exists" error is interesting... It seems like vpopmail couldn't read the table, so decided it should make a new one. The "out of order" stuff above makes me think it had another issue reading a table (ie: the commands weren't out of order, but one of them failed).

Here's ldd output on the new commands:

[EMAIL PROTECTED]/usr/local/src/toaster/vpopmail/vpopmail-5.4.7]# ldd vuserinfo
vuserinfo:
libmysqlclient.so.12 => /usr/local/lib/mysql/libmysqlclient.so.12 (0x28074000)
libz.so.2 => /usr/lib/libz.so.2 (0x28094000)
libm.so.2 => /usr/lib/libm.so.2 (0x280a1000)
libcrypt.so.2 => /usr/lib/libcrypt.so.2 (0x280bc000)
libc.so.4 => /usr/lib/libc.so.4 (0x280d5000)


And similar from the working box:

[EMAIL PROTECTED]/usr/local/src/toaster]# ldd `which vuserinfo`
/usr/local/bin/vuserinfo:
libmysqlclient.so.12 => /usr/local/lib/mysql/libmysqlclient.so.12 (0x28074000)
libz.so.2 => /usr/lib/libz.so.2 (0x28095000)
libm.so.2 => /usr/lib/libm.so.2 (0x280a3000)
libcrypt.so.2 => /usr/lib/libcrypt.so.2 (0x280bf000)
libc.so.4 => /usr/lib/libc.so.4 (0x280d8000)


Any ideas?

Thanks,

Charles




Reply via email to