On Thu, November 25, 2004 9:50 am, Tom Collins said:
> What are the permissions on qmailadmin?
> -rwsr-sr-x    1 vpopmail vchkpw     438385 Aug 26 09:53 qmailadmin

Mine was not ug+s, but that would not have changed.  I went ahead and
chmoded it so that it looked identical to yours, however logins still
failed.

> And what does your qmail-smtpd run file look like?

It's the stock run file that comes with Gentoo's build of QMail, with a
change out of /bin/checkpassword for /var/vpopmail/bin/vchkpw.  After
variable substitution, it boils down to this:
exec /usr/bin/softlimit -m 8000000 /usr/bin/tcpserver -p -v -R -x
/etc/tcprules.d/tcp.qmail-smtpd -c 40 -u `id -u qmaild` -g `id -g qmaild`
0.0.0.0 smtp rblsmtpd -r relays.ordb.org -r bl.spamcop.net -r
dnsbl.sorbs.net -r sbl-xbl.spamhaus.org /var/qmail/bin/qmail-smtpd
midgard.osss.net /var/vpopmail/bin/vchkpw /bin/true 2>&1

I don't believe there is anything wrong with that file because it worked
fine before with vchkpw, and works fine now with checkpassword, just not
vchkpw.

> Did you fix the UID/GID in the /etc/passwd file?

Of course.  Like I said, qmail-send is currently delivering mail fine, and
I can access the mail fine via bincimap...the former depends on vpopmail
working, and the latter uses vchkpw...

I've also found I can run vchangepw and change a password fine, but I
still cannot log in to smtp or qmailadmin as that user.

> Are you sure your qmail-smtpd is running as user vpopmail (with the
correct uid/gid)?

Why would it?  From the above run file, it appears to run as qmaild:qmaild
(201:200) - this has never changed, it was the same when it was working
fine yesterday.  It is delivering mail to vpopmail users sent in via
regular SMTP perfectly...it's just started rejecting SMTP AUTH connections
which users of my system use via TLS to relay.

Cheers,

-- 
Casey Allen Shobe
[EMAIL PROTECTED]

Reply via email to