On Wed, 8 Dec 2004 10:39:35 -0800, Tom Collins <[EMAIL PROTECTED]> wrote:
> On Dec 8, 2004, at 8:04 AM, Pedro Pais wrote:
> > When a user tries to authenticate itself, the first time vchkpw fails
> > with:
> >
> > "Dec  6 21:50:08 [vpopmail] vchkpw-smtp: password fail"
> >
> > but then it succeeds immediatly after:
> >
> > "Dec  6 21:50:13 [vpopmail] vchkpw-smtp: (PLAIN) login success"
> >
> > This is very annoying, besides the fact that this only happens with
> > Thunderbird, with other e-mail clients they give an error message and
> > the connection is terminated. Is there any way to solve this thing?
> It looks like the client is trying CRAM-MD5, failing, and then using
> PLAIN authentication.
> You probably have an older patch, or a version problem between the
> smtp-auth patch and vpopmail.  The older patch sent the information in
> the incorrect order, and vpopmail was written to accept it in that
> order.  We fixed vpopmail for the 5.4.0 release, but it required
> updating to the correct SMTP AUTH patch.
> If you're using vpopmail 5.4.0 and later, make sure you're using an
> up-to-date patch that passes the MD5 challenge and response in the
> correct order.  The patch in vpopmail's contrib directory works
> properly.
> --
> Tom Collins  -  [EMAIL PROTECTED]
> QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
> Info on the Sniffter hand-held Network Tester: http://sniffter.com/
Thanks a lot for your tips, but it still doesn't work. :( I'm using
gentoo, that already has qmail way patches. I tried to compile it with
the patch in the contrib dir, and it worked out. But the result is
just the same.
But I guess you're totally right. I've tried more extensively and with
Outlook Express it doesn't give any error (I suppose OE doesn't use
I'm using vpopmail 5.4.6, and qmail is already patched with smtp auth,
but still nothing. Any thing else you can remember?

Pedro Pais
Skype name: pedro.pais
Get Firefox! 

Reply via email to