I need a help here.
i am makeing a new mailserver. i installed qmail, vpopmail, maildrop, etc...
the mail server works fine.
the problem is that i have many .qmail-user files that redirect mail with
vdeliver mail, exemple:
| /opt/vpopmail/bin/vdelivermail '' /opt/vpopmail/domains/test.com/user

It works fine in old mail server but in the new one it fails.
in qmail-send log i got the folowing message:
deferral: Unable_to_run_/bin/sh:_

i traced back and i know that it happens when vdelivermail execute the
execv command.
i change de vdelivermail to print errno message and the message was
"too many open files".

it happens because vdelivermail was not supose to return in execv command, but it does and happens to execute too many vdelivermail process

i did check /bin/sh and /bin/bash permissions and it's ok (755).
just to make shure i've changed to 777 and the error persist.

i checked out qmail and vpopmail permissions and it was what
it supose to be

The diferences between de old server and the new server are:

- vpopmail version(5.4.5 in the old one, 5.4.10 in the new one)
- qmail location (/var/qmail in the old one, /opt/qmail in the new one)

i tried to downgrade vpopmail to 5.4.5 and the same error happens.
i compiled all software informing then where qmail is installed and
i don't think this could be the problem... (am i right?)

the vdelivermail in .qmail-default (bounce) works fine, only in
.qmail-user or .qmail-user-default the error hapens.

please, help me. I don't know what to do anymore.


Mario Cardia
(i'm brazilian, so sorry by my poor english)

Reply via email to