On Sat, 2005-04-16 at 08:46 -0400, Tom Collins wrote:
> On Apr 15, 2005, at 8:28 PM, Jeff Schmidt wrote:
> > I'm leaning toward a qmail issue vs. a vpopmail issue, but I admit I
> > don't know how much vpopmail is involved w/ the smtpd process.
> >
> > this is the relevant process running on the server:
> > /usr/bin/tcpserver -p -v -R -x /etc/tcp.smtp.cdb -c 40 -u 201 -g 200
> > 0.0.0.0 smtp /var/qmail/bin/qmail-smtpd
> > mail.dubuquepeterbilt.com /var/vpopmail/bin/vchkpw /bin/true
> 
> It sounds like you've got two possible things going on.
> 
> First, trusted hosts can't relay mail.  This is entirely qmail 
> referencing /etc/tcp.smtp.cdb and does not involve vpopmail.
yeah, that's what I thought.

> 
> What has changed between the time relaying worked and it didn't work?  
> Did you patch qmail-smtpd in any way?
I wish I knew. I'm not the only one w/ root...
I'm not even sure *when* it broke. it's not heavily used.

> 
> Can tcpserver read /etc/tcp.smtp.cdb when running as user 201 and group 
> 200?
I assume so - perms on /etc/tcp.smtp.cdb are 644.
I am able to run this without any errors on the command line:
tcpserver -c 5 -x /etc/tcp.smtp.cdb -g 200 -u 201 localhost
26 /var/qmail/bin/qmail-smtpd

> 
> The second possible problem is that you can't authenticate.  If you try 
> a manual session with qmail-smtpd and use AUTH LOGIN or AUTH PLAIN 
> (http://fehcom.de/qmail/qmail.html has info on the command formats, 
> you'll need a base64 encoder to generate the strings).
> 
> If SMTP AUTH doesn't work either, you should try checking 
> /var/log/maillog to see if vchkpw is indicating an invalid login.
I don't think smtp-auth ever worked. I don't recall seeing any reference
of an smtp-auth patch in the stable ebuild (qmail-1.03-r13), and I'm
pretty sure (roaming users) is disabled in the vpopmail (5.4.6-r1)
ebuild, as well. there are no references to vchkpw in
my /var/log/mail.log

> 
> If both relay and auth are failing, then maybe something has happened 
> to your qmail-smtpd such that it's ignoring the RELAYCLIENT environment 
> variable.
that's what I was thinking, but don't know how to verify it. the
time/date on the qmail-smtpd binary is from the original install,
though.

> 
> --
> Tom Collins  -  [EMAIL PROTECTED]
> QmailAdmin: http://qmailadmin.sf.net/  Vpopmail: http://vpopmail.sf.net/
> You don't need a laptop to troubleshoot high-speed Internet: 
> sniffter.com
> 

Reply via email to