What is in your authlibd file. The file where you spicy the
authentication module. I'm running the same Gentoo packages as you as
well on my PPC 2.6.11 and every works very sweet. As I can remember I
could not authenticate as well just because my authlibd file had all
the authentication programs listed in it instead of one.

HTH
Zeno

On 4/26/05, Jeffrey Wong <[EMAIL PROTECTED]> wrote:
> I'm trying to setup a new mailserver with qmail and vpopmail.  I've
> installed both, and have setup user accounts.  I'm running into
> problems when trying to test the setup to make sure things are
> working.
> 
> Running this command:
> printf "[EMAIL PROTECTED]" | vchkpw `which id` 3<&0
> yields this result:
> uid=0(root) gid=0(root)
> groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy),20(dialout),26(tape),27(video)
> 
> I run the same command on a working server and get this:
> uid=89(vpopmail) gid=89(vpopmail)
> groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy),20(dialout),26(tape),27(video),35(games)
> 
> I can't authenticate any users on the new server.  My best guess is
> that the discrepancy between the two outputs is the source of the problem.
> 
> Some extra information:
> Both servers are running Gentoo Linux.  The server with the problem is
> running kernel 2.6.10.  The working server is running kernel 2.4.26.
> Though the kernel version isn't the source of the problem as I was
> able to make a clean install on a 2.6 kernel without any problems.
> 
> Can someone point me to where this problem may be coming from?
>

Reply via email to