At 07:04 AM 6/6/2005, you wrote:
keeping up my monologue here, i've copied back in place all my 5.3.18 binaries, and, at least for the moment, the failures appear to be no longer occurring.

of course, now i'm using a binary built before the switch to only forwards, rather than forwards and aliases. i presume that's not a problem for the time being.

update, i *believe* i've solved the problem, and if so, then i'm *sure* that i'm an idiot: i compiled vpopmail with mysql replication support. I do't have a replication server set up to act in that capacity. recompiling with --enable-mysql-replication removed and the failures appear to have stopped.

i outwitted my own damn self. argh.

one unrelated issue, not sure if i want to start a new thread for it or not.....i compiled with --disable-rebuild-tcpserver-file, but the tcp.smtp.cdb file continues to be rebuilt. i'm using Matt Simerson's tcpserver patch to query mysql for the relay control.

here's my complete config options:

./configure \
--prefix=/u1 \
--exec-prefix=/u1 \
--disable-domain-quotas \
--disable-ip-alias-domains \
--disable-rebuild-tcpserver-file \
--enable-clear-passwd=yes \
--enable-learn-passwords=yes \
--enable-roaming-users=yes \
--enable-relay-clear-minutes=722 \
--enable-incdir=/usr/local/mysql/include \
--enable-libdir=/usr/local/mysql/lib \
--enable-libs=mysqlclient \
--enable-auth-module=mysql \
--enable-mysql-limits \
--enable-logging=p \
--enable-logname=vpopmail \

Paul Theodoropoulos

Reply via email to