Hi, I'm having a problem here that has been baffling me for a few days now.
I've set up mail servers before using Qmail/Vpopmail/Courier-IMAP on Gentoo
boxes, and I just set up another one over the weekend.  I am running into a
strange problem though that I can't seem to figure out.

I can use vadddomain, vadduser, vdeluser, and vdeldomain just fine to add/remove
domains and users.  I also don't have problem logging in to the IMAP server. (I
haven't worked to see if I can actually send/receive mail through qmail yet,
since I don't have my domains/users working properly yet).  However, when I
install Qmailadmin, I get an "Invalid Login" error.  I checked my apache logs,
and this is what I see:

vmysql: sql error[3]: MySQL server has gone away, referer:
https://mydomain.net/cgi-bin/qmailadmin

So I tried a few other vpopmail commands, and I found that vdominfo and
vuserinfo were returning no output (i.e., they think that there are no users or
domains).  This seems very strange to me, since I can obviously use vpopmail to
add domains and users, as well as log in to a Courier IMAP server.

For the record, I'm currently running Vpopmail 5.4.6 and MySQL 4.1.12 on a
Gentoo Linux x86 2005.0 box.

Is there something I could possibly have wrong somewhere?  Any help anyone can
provide would be very greatly appreciated, and if there is more info I can
provide please let me know.

Adam

Reply via email to