I 'm sure slapd is running
port 389(ldap) is listening
my vpopmail.ldiff contains as following;
dn: dc=example,dc=com
objectclass: dcObject
objectclass: organization
o: Example Company
dc: example
 
dn: cn=Manager,dc=example,dc=com
objectclass: organizationalRole
cn: Manager
When I write "ldapadd -x -D "cn=Manager,dc=example,dc=com" -W -f vpopmail.ldif"
I got an error;
Enter LDAP Password:
adding new entry "dc=example,dc=com "
ldapadd: update failed: dc=example,dc=com
ldap_add: Server is unwilling to perform (53)
        additional info: referral missing
 
What shall I do ?
Could you give me an example file of ldiff ?
----- Original Message -----
Sent: Monday, September 05, 2005 6:16 PM
Subject: Re: [vchkpw] I wasn't able to make a folder named vpopmail.ldiff

Ok. I am not familiar with FreeBSD but you need to make sure OpenLDAP is correctly setup. I would suggest you read the following: http://www.openldap.org/doc/admin23/quickstart.html

-dougal


Bulent wrote:
I 'm using openldap-2.1.23
Also I 'm using LDAP first time
----- Original Message -----
Sent: Monday, September 05, 2005 5:42 PM
Subject: Re: [vchkpw] I wasn't able to make a folder named vpopmail.ldiff

Hi,

What version of OpenLDAP are you using?

The error message is due to a failed bind from the ldapadd. You are attempting to bind using 'cn=vpopmail111' Have you already created this entry in the directory? Is this your first time using LDAP?

-dougal


Bulent wrote:
Hello
 
I use qmail on Freebsd5.4.
I read README.ldap in /path/vpopmail5.4.6
I have installed  vpopmail5.4.6 with ldap module. 
I prepared at vldap.h in /path/vpopmail5.4.6 as following;
      #define VLDAP_SERVER "localhost"
      #define VLDAP_PORT LDAP_PORT
      #define VLDAP_USER "cn=vpopmail111, o=vpopmail"
      #define VLDAP_PASSWORD "111"
      #define VLDAP_BASEDN "o=vpopmail"
 
I started /usr/local/libexec/slapd
it worked
when I wrote "ps axf" in the server
I could below line
52625  ??  Ss     0:00.97 /usr/local/libexec/slapd
I 'm the next step.
I tried to run  below line
ldapadd -f vpopmail.ldif -x -w vpoppasswd -D'cn=vpopmail111,o=vpopmail'   in /usr/local/etc/openldap
I got an error as below
ldap_bind: Invalid credentials (49)
 
What should the folder named vpopmail.ldif be contain ?
Could you send me an example ldiff file ?
 
 
 


Reply via email to