I was told that its an issue with vpopmail. It does look like it has something to do with a vpopmail library. I compiled vpopmail from source and am trying to follow this install.


http://www.shupp.org/toaster/

On Thu, Sep 08, 2005 at 06:32:11PM -0700, colin williams enlightened us:
>  Im getting this message when I try to compile IMAP
>
> First i didnt have gmake but i just created a link to make.
>
> Here's the real trouble
>

> Linking libauthvchkpw.la < http://libauthvchkpw.la/>
> /usr/bin/ld: /home/vpopmail/lib/libvpopmail.a(vpopmail.o): relocation
> R_X86_64_3 2 can not be used when making a shared object; recompile with
> -fPIC
> /home/vpopmail/lib/libvpopmail.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> gmake[3]: *** [libauthvchkpw.la < http://libauthvchkpw.la/>] Error 1
> gmake[3]: Leaving directory `/var/src/courier-authlib-0.56'
> gmake[2]: *** [install-recursive] Error 1
> gmake[2]: Leaving directory `/var/src/courier-authlib-0.56'
> gmake[1]: *** [install] Error 2
> gmake[1]: Leaving directory `/var/src/courier-authlib-0.56'
> gmake: *** [install-strip] Error 2
> test -f /usr/local/etc/authlib/authdaemonrc.dist && /usr/bin/perl
> ././sysconftoo l /usr/local/etc/authlib/authdaemonrc.dist || true
> test -f /usr/local/etc/authlib/authmysqlrc.dist && /usr/bin/perl
> ././sysconftool /usr/local/etc/authlib/authmysqlrc.dist || true
> test -f /usr/local/etc/authlib/authpgsqlrc.dist && /usr/bin/perl
> ././sysconftool /usr/local/etc/authlib/authpgsqlrc.dist || true
> test -f .dist && /usr/bin/perl ././sysconftool .dist || true
>
>

You need to compile vpopmail with the -fPIC flag. You'll probably want to
direct further questions about that to either a debian list if it's a .deb
or the vpopmail list if you compiled from source.

Matt

Reply via email to