At 17.13 09/03/2006, you wrote:

I'm hoping somebody will be able to help me with a problem I appear to be
having with chkuser 2.0.

I built my qmail installation from the qmailrocks bundle, which I've done a
few times in the past so I haven't had any problems there.

I was looking for a suitalbe solution to block SMTP delivery to unknown
local recipients and I would prefer to use chkuser instead of the what
appears to be a suitalbe alternative, validrcptto, as I anticipate quite a
high number of users and regular updates to accounts & aliases. With
validrcppto I need to build & maintain another user database outside of the
vpopmail configuration.

I have downloded the latest tarball of chkuser and followed the installation
instructions. The patches would not apply to my qmailrocks source, so I
implemented the changes by hand.

Initially compilation failed due to repeated dns.o references, that was my
fault and was easily repaired.

The changes also seem to have affected the compliation of spfquery.c - I
managed to fix this though and compliation now appears to be successful.

However - if I run the new qmail-smtpd binary to check the funcationality as
recommended it does not appear to be doing any rcpt to: checks - an ok
result is returned no matter what username I supply before a valid rcpt

Can anyone make any suggestions as to what I can do to try and locate the

You should give more informations...

Have you tried what's suggested in ?



Reply via email to