Apparently, when the mysql connection is lost, it doesn't reconnect as it should, I killed the process in mysql and tried to reconnect via imap and got the error(with no other mysql processes). I had assumed if that if IMAP connections were failing in this situation, pop3 connections would also. If I restart dovecot, then the connection is resumed.

Any guidance on what I would need to do for it to reconnect when connection is dropped would be very helpful, I've read somewhere that it may need to be patched because it's returning true for being connected to mysql regardless of if it actually is, but I can't find the post now.

James Cooke

On 3/9/06, james cooke <[EMAIL PROTECTED]> wrote:
I've had it happen when there's only been a couple of connections on the mysql processlist, and the server is mostly for my testing purposes thus far, so it getting slammed with connections is highly unlikely. I'll up the connection limits and see if anything improves just to check for sure.

Even if this were the case, after the connections drop, wouldn't it be expected that you'd be able to connect then? When the problem happens, it's permanent.

On 3/8/06, Michael Krieger <[EMAIL PROTECTED]> wrote:
Check your connection limits to the MySQL server.  Seems to occasionally happen when a flood of smtp connections or pop connections opens up a lot of MySQL backends.  Essentially it means that it tried to run its database queries and the server isn't there and has broken or didn't accept the connection.


james cooke < [EMAIL PROTECTED]> wrote:

After a few hours of running - I haven't narrowed it down to a certain time, it seems to vary - IMAP connections fail with:
dovecot: Mar 08 16:29:59 Error: auth(default): vmysql: sql error[3]: MySQL server has gone away

Setup is FreeBSD 5.4, qmail 1.03, vpopmail 5.4.13, dovecot 1.0, mysql 5.0.18.

I thought the issue was with the imap server, but it occurred with courier-imap also.

Auth with pop3 continues to work, and if I reset dovecot then imap begins to work again temporarily, as it did with courier-imap.

I'm assuming this might be some sort of MySQL version or connection timeout issue, but I'm at a loss on where to go from here, I'm fairly new to this area in general, any feedback would be very welcome.

James Cooke

Reply via email to