John Simpson wrote:
> On 2006-04-01, at 0547, Rick Widmer wrote:
>> John Simpson wrote:
>>> let me suggest an alternative- instead of "login user pass
>>> compact", how about "login/compact user pass"? this allows the
>>> password to be the last thing on the line, and therefore contain
>>> spaces, and still allows for a "compact" option.
>> What do you think about login | clogin | slogin?
Can we just take step back here...?
We are proposing alternative login methods because the current "login"
method returns all user information after a successful login, yes?
Why not change the behaviour so that "login" does just that - it logs
in, and add another command that returns the information, e.g. "get"
So, a system only needing to validate credentials would just need to
login and quit.
"get" would take parameters, e.g:
There could also be a "set" command which ... you guessed it!
set name "New Name"
set system_admin_privileges 1
What do you think?