hello all,

i am trying to upgrade my vpopmail server. am currently on 5.4.13 and
trying to updrage to 5.4.16. i am using onchange patch available at

i am using postgreSQL as my autentication server, its a machine on my
network, for vpopmail to access that machine i edited vpgsql.h, below
are changes i made for the same.

# diff vpgsql.h ./vpopmail-5.4.16/vpgsql.h
< #define DBHOST "<hostname>"
< #define DBUSER "<db user>"
< #define DBPASSWD "<db password>"
< #define PG_CONNECT "host=" DBHOST " user=" DBUSER " password="
DBPASSWD " dbname=" DB
#define PG_CONNECT "user=postgres dbname=" DB

my configuration options are
# ./configure \
--disable-roaming-users \
--enable-logging=p \
--disable-ip-alias-domains \
--disable-passwd \
--enable-clear-passwd \
--enable-auth-module=pgsql \
--disable-many-domains \
--enable-auth-logging \
--enable-sql-logging \

the final configuration results are
          vpopmail 5.4.16
           Current settings

vpopmail directory = /home/vpopmail
domains directory = /home/vpopmail/domains
              uid = 518
              gid = 513
    roaming users = OFF --disable-roaming-users (default)
password learning = OFF --disable-learn-passwords (default)
    md5 passwords = ON  --enable-md5-passwords (default)
     file locking = ON  --enable-file-locking (default)
vdelivermail fsync = OFF --disable-file-sync (default)
    make seekable = ON  --enable-make-seekable (default)
     clear passwd = ON  --enable-clear-passwd (default)
user dir hashing  = ON  --enable-users-big-dir (default)
address extensions = OFF --disable-qmail-ext (default)
         ip alias = OFF --disable-ip-alias-domains (default)
      auth module = postgres --enable-auth-module=postgres
      sql logging = ON  --enable-sql-logging
         auth inc = -I/usr/include/pgsql
         auth lib = -L/usr/lib/pgsql -lpq
 system passwords = OFF --disable-passwd (default)
       pop syslog = show failed attempts with clear text password
     auth logging = ON  --enable-auth-logging (default)
one domain per SQL table     = --disable-many-domains

but when i run make i end up in the following errors

gcc  -g -O2 -Wall   -o valias  valias.o libvpopmail.a
-L/usr/lib/pgsql -lpq  -lcrypt
valias.o(.text+0x440): In function `main':
/downloads/qmailrocks/vpopmail-5.4.16/valias.c:89: undefined reference
to `valias_select_names'
undefined reference to `valias_select_names_next'
undefined reference to `valias_select_names_end'
undefined reference to `valias_select_names_end'
collect2: ld returned 1 exit status
make[2]: *** [valias] Error 1
make[2]: Leaving directory `/downloads/qmailrocks/vpopmail-5.4.16'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/downloads/qmailrocks/vpopmail-5.4.16'
make: *** [all] Error 2

i even tried compiling without the onchange patch and my changes in
vpgsql.h file but the results are the same.

the changes i did for vpgsql.h work perfectly fine with vpopmail-5.4.13

i hope vpopmail-5.4.16 does not require any changes in the db as the
vpopmail db on the autentication machine is shared by other
applications and qmr installation on my network.



Reply via email to