On Mon, 28 Aug 2006 [EMAIL PROTECTED] wrote:

> On Mon, 28 Aug 2006, Peter Palmreuther wrote:
> > Hello List,
> >
> > On Monday, August 28, 2006 at 5:04:23 PM up wrote:
> >
> > > I've configured this before, but I can't figure out why it isn't working
> > > this time (new server).  I compiled vpopmail with roaming users, and it's
> > > putting the open-smtp where it always has, under ~vpopmail/etc/.  In the
> > > past, tcpserver always found it, AND the /etc/tcp.smtp.cdb file even
> > > though it was invoked thusly:
> >
> > > -x/etc/tcp.smtp.cdb
> >
> > > How does one get tcpserver to recognise the rules in both files?
> >
> > Simple. Make /etc/tcp.smtp.cdb a symlink to ~vpopmail/etc/tcp.smtp.cdb.
> Sorry if I'm still confused...on the old server, I actually had simlinks
> the other way around.  In ~vpopmail/etc/ I had simlinks to /etc/tcp.smtp
> and /etc/tcp.smtp.cdb and it worked.  It doesn't on the new install.
> I tried reversing it the way you recommended, but it still doesn't work.
> (chowned vpopmail all the files, although open_smtp always gets created as
> root owned).
> I assume that somehow tcpserver either sees the open_smtp file when you do
> this, of its contents get somehow included in the tcp.smtp file, but I'm
> not seeing it...how does tcpserver know about the contents of the
> open_smtp file?

replying to my own post...I found that FreeBSD ports, where I installed it
from, for some reason has some nonsensical defaults, such as:


yet, I put in a symlink from /usr/local/vpopmail/etc to
/home/vpopmail/etc, which I would have thought would have fixed this, but
it didn't...

James Smallacombe                     PlantageNet, Inc. CEO and Janitor
[EMAIL PROTECTED]                                                           

Reply via email to