Good morning,

Seems I am posting all over the internet these last two weeks, but I can't seem to grab my butt lately. I got FreeBSD running on the Sunfires, netqmail installed, Simscan install, ClamAV installed, everything is working fine. Last step, smtp-auth, why did I try? I should have let today end on a good note.

Nothing different from my other vpopmail installs. I can login to mysql from the server no problems. That I did check right away.

FreeBSD 6.2
Vpopmail 5.4.17
Netqmail 1.05 (new for me, normally patched qmail my self)
  (Installation of qmail-smtpd AUTH 056 (Build 2004272152823)
   finished at Tue Mar  6 12:43:03 EST 2007)
Mysql 4.0, also tried 4.1.


bash-2.05b# cat args-vpopmail
./configure \
--enable-tcpserver-file=/var/qmail/control/tcp.smtp.cdb \
--enable-learn-passwords \
--enable-vpopuser=vpopmail \
--enable-vpopgroup=vchkpw \
--enable-incdir=/usr/local/include/mysql \
--enable-libdir=/usr/local/lib/mysql \
--enable-clear-password \
--enable-auth-module=mysql \
--enable-mysql-replication \


No errors when building, seems to work,
bash-2.05b# /home/vpopmail/bin/vuserinfo [EMAIL PROTECTED]
Error. Domain was not found in the assign file
name:   dave.list
passwd: $1$jB.dCgrW$GbolDS0pK/BMUJuoHwhq20
clear passwd: XXXXXX
comment/gecos: dave.list
uid:    0
gid:    0
flags:  0
gecos: dave.list
limits: No user limits set.
dir:       /home/vpopmail/domains/
quota:     NOQUOTA
usage:     NOQUOTA
last auth: Tue Mar  6 15:02:40 2007
last auth ip:


My run file is unchanged except for IP and host,
bash-2.05b# cat /service/qmail-smtpd-auth/run

QMAILDUID=`id -u vpopmail`
NOFILESGID=`id -g vpopmail`
MAXSMTPD=`head -1 /var/qmail/control/concurrencyincoming`
if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" ]; then
    echo QMAILDUID, NOFILESGID, or MAXSMTPD is unset in
    echo $0
    exit 1
exec /usr/local/bin/softlimit -m 30000000 \
/usr/local/bin/tcpserver -v -P -R -h -l -x /var/qmail/control/tcp.smtp-auth.cdb -c "$MAXSMTPD" \
        -u "$QMAILDUID" -g "$NOFILESGID" 587 \
        /usr/local/bin/fixcrio /var/qmail/bin/qmail-smtpd-auth \
            /home/vpopmail/bin/vchkpw /usr/bin/true 2>&1


The odd thing is I get this error in my /var/log/qmail/smtp-auth/current when I try to send mail,
bash-2.05b# cat /var/log/qmail/smtpd-auth/current | tai64nlocal
2007-03-06 14:51:08.554888500 tcpserver: status: 1/100
2007-03-06 14:51:08.555269500 tcpserver: pid 70711 from
2007-03-06 14:51:08.583719500 tcpserver: ok 70711 2007-03-06 14:51:08.760630500 vmysql: error creating table 'lastauth': Table 'lastauth' already exists 2007-03-06 14:51:08.761187500 vmysql: sql error[f]: delete command denied to user: '[EMAIL PROTECTED]' for table 'lastauth'
2007-03-06 14:51:09.064200500 tcpserver: end 70711 status 0


The one thing that is different, is I have an empty assign file. This server is used for smtp-auth *outbound* only service. So, just for fun I added the test domain to the assign file, still fails.

I built and tried the checkpassword program, just to get a better idea what was happening (I like this prog, used it before).

bash-2.05b# /usr/local/src/vpopmail-5.4.17/contrib/checkpasswd_debug -vvv -c /home/vpopmail/bin/vchkpw -l -u89 -g89
switching from gid 0 to 89 (vchkpw)
switching from uid 0 to 89 (vpopmail)
Please enter password: xxxxx
"/home/vpopmail/bin/vchkpw" started with pid 71902
sending "ldg%tls.netNULLxxxxxNULL0NULL" (21 bytes) to checkpassword with uid/gid: 89/89
vmysql: error creating table 'lastauth': Table 'lastauth' already exists
vmysql: sql error[f]: delete command denied to user: '[EMAIL PROTECTED]' for table 'lastauth'
normal exit from checkpassword
checkpassword exit value: 6

Tried to search for an answer, but no luck. Is there any additional info I can provide?


Three years now I've asked Google why they don't have a
logo change for Memorial Day. Why do they choose to do logos
for other non-international holidays, but nothing for

Maybe they forgot who made that choice possible.

Reply via email to