Chad E. Berg wrote:
Here is the situation: I have an alias domain which is
aliased to  If I run '~vpopmail/bin/valias' I can see all of the aliases for the domain.  However if
I run '~vpopmail/bin/valias' I get no output at all.
Furthermore if I run '~vpopmail/bin/valias -n' (or with
any domain) I get a seg. fault.

Attached is the discussion with John Simpson from the qmailrocks mailing
list.  He believes this issue is a bug in vpopmail.

I am using vpopmail v5.4.18 w/ MySQL support.  Here is my configure line:
./configure --enable-logging=p --enable-auth-module=mysql --disable-passwd
--enable-clear-passwd --disable-many-domains --enable-auth-logging
--enable-sql-logging --enable-valias --disable-mysql-limits
--enable-roaming-users --enable-onchange-script


I can at least confirm that there is no problem with 5.4.17 using MySQL. My alias reporting works just fine.

bash-2.05b# ./vuserinfo -v
version: 5.4.17

./configure \
--enable-tcpserver-file=/shared/qmail/control \
--enable-learn-passwords \
--enable-vpopuser=vpopmail \
--enable-vpopgroup=vchkpw \
--enable-qmail-ext \
--enable-incdir=/usr/local/include/mysql \
--enable-libdir=/usr/local/lib/mysql \
--enable-clear-password \
--enable-auth-module=mysql \


Three years now I've asked Google why they don't have a
logo change for Memorial Day. Why do they choose to do logos
for other non-international holidays, but nothing for

Maybe they forgot who made that choice possible.


Reply via email to