I'm not sure what version you are trying this with. I just tested it with the unreleased version in CVS and it is working. I don't know that I fixed anything, but in the process I updated some of the error reporting, including the fact that vdeluser checked for the user before the domain. Now if you try to attempt to delete a user from a non-existent domain it reports that the domain doesn't exist rather than the user.


#vadddomain test.domain password
ONCHANGE add_domain - test.domain

#vadddomain test.domain password
Error: Domain already exists

#vadduser [EMAIL PROTECTED] password
ONCHANGE add_user - [EMAIL PROTECTED]

#vadduser [EMAIL PROTECTED] password
Error: Username exists

#vdeluser [EMAIL PROTECTED] password
ONCHANGE del_user - [EMAIL PROTECTED]

#vdeluser [EMAIL PROTECTED] password
Error: User does not exist

#vdeldomain test.domain
ONCHANGE del_domain - test.domain

#vdeldomain test.domain
Error: Domain does not exist

#vdeluser [EMAIL PROTECTED] password
Error: Domain does not exist


This DOES NOT mean CVS is ready for use, or release, only that I don't see this bug in CVS.

What version are you using?

Rick



Jonathan wrote:
That's the strange thing. They're both removed from the vpopmail directory and the MySQL db.

16 maj 2007 kl. 02.32 skrev Remo Mattei:


Jonathan wrote:
This is the exact procedure:

# vadddomain test.domain
Please enter password for postmaster:
enter password again:
# vadduser [EMAIL PROTECTED]
Please enter password for [EMAIL PROTECTED]:
enter password again:
# vdeluser [EMAIL PROTECTED]
Failed to delete user from auth backend
Error: Illegal username
# vdeldomain test.domain
Warning: Failed while attempting to delete domain from auth backend

Reply via email to