I apologize in advance as a Google search didn't bring anything up that was helpful.

I'm having issues with one domain for modifications to the vpasswd file and qmailadmin file. Any time I run a vpopmail program on this one domain I'm getting a segmentation fault.

It's an unusually large amount of users for one of our domains, and this problem has happened before

For example here a not-so typical session (vmoduser options removed as well as domain & email address):
[EMAIL PROTECTED]:~# ~vpopmail/bin/vmoduser -v
version: 5.4.20
. (options deleted)
[EMAIL PROTECTED]:~# cd ~vpopmail/domains/XXXXXXXX.org/
[EMAIL PROTECTED]:/home/vpopmail/domains/XXXXXXXX.org# wc -l vpasswd
501 vpasswd
[EMAIL PROTECTED]:/home/vpopmail/domains/XXXXXXXX.org# ~vpopmail/bin/vmoduser -a [EMAIL PROTECTED]
Segmentation fault

Are there any utilities that I can run to check the state of the vpasswd file? It seems that the cdb is being created with no issues and an 'eyeball look' at the file doesn't have anything outstanding, but there are 500 lines and as you can imagine the fields start to blur :-)

Server system:
Ubuntu Linux Server 7.04
Quad Core Xeon
4 gigs of RAM
vpopmail-5.4.21 (not sure why vmoduser version reads 5.4.20)

Thanks for any advice!

   Jeffrey D. Gordon
   Sr. Programmer/Network Administrator
   iThinc.net - Dynamic Media

Reply via email to