I'm running netqmail-1.05 and vpopmail-5.4.16 on Gentoo, but I don't
believe this Gentoo specific (if it is, apologies in advance).

My problem is that for one of my domains I can't seem to get qmail to
follow the right .qmail file. I have an account, e.g. bob, which is
located in /home/vpopmail/domains/example.org/bob and I setup a
.qmail-bob-default in /home/vpopmail/domains/example.org which delivers
to the bob account. This lets me use any email address in the format
[EMAIL PROTECTED] and it will all end up in the same account. Its
perfect for one-time email addresses you need to see or emails that
might get spammed (like mailing lists).

So I setup one such address, [EMAIL PROTECTED] (clamav mailing
list) and soon enough it started to get spam to it, so I thought i'd
ditch it. Here's my problem, if I setup .qmail-bob-clamav (which will
delete emails) qmail doesn't use it, it still uses .qmail-bob-default
(so I still get the spam).

Am I missing something obvious? I always thought -default was checked
last and I can't see why its not using the exact match on

At first I thought it was because valias was enabled and it was using
aliases/forwards in mysql, but I disabled that option and it hasn't made
a difference.  I've even ditched mysql options completely and it
still doesn't work.

Thanks in advance.

Reply via email to