I'm getting a segfault when running vuserinfo -D <domain>, trying to list addresses for a given domain. I also get a segfault when trying to use the qmailadmin web interface to list addresses, which I'm guessing is because it uses vuserinfo.

The situation is a bit complicated in that I moved all the data and users from one server to another. On the original server, vuserinfo -D works. What I did to perform the move was copy the domain directory trees and the MySQL tables. Receiving mail, authorizing through courier-authlib, and pretty much everything else works.


One thing I've tried is removing the domains completely (after backing all data up), so that the vpopmail database tables were empty, then creating the domains again with vadddomain. Before restoring any users or mail directories, I tried vuserinfo -D, and it again caused a segfault. I have the domains directory as a symlink to a different mount point, so I also tested with an actual directory, which had no effect. Since this didn't work, I restored the original tables.

This is with vpopmail 5.4.16 on a Gentoo amd64 system. The original server is also Gentoo amd64, and also 5.4.16.

Some other details:

vdominfo = works
vadduser = works
vuserinfo <user>@<domain>  = works
valias -s <domain> = works
valias -n <domain> = segfault

I'm at a loss to understand what the problem could be. Any ideas on what I can look at to figure this out?


!DSPAM:478eafd5310546903420565!

Reply via email to