Whether I run as root or vpopmail, the same error occurs.

When I run:
  ./vdeluser [EMAIL PROTECTED]
I receive: 
  Failed to delete user from auth backend
  Error: Illegal username

But it does seem to delete the user from the database because when I
run it again:
  ./vdeluser [EMAIL PROTECTED]
I receive:
  Error: User does not exist

Also, it doesn't delete the user's mailbox directory.  After I manually
delete it, I can run ./vadduser [EMAIL PROTECTED] without error.

Why is this?

I'm using vpopmail with mysql.

It is a fresh install of vpopmail v5.4.25 on CentOS v5.1 (x86 32-bit)
with the following configuration options:

./configure --enable-learn-passwords \
  --enable-onchange-script \
  --enable-spamassassin \
  --enable-spamc-prog=/usr/bin/spamc \
  --enable-auth-module=mysql \
  --enable-sql-logging \
  --enable-mysql-limits \

And, since I'm new to vpopmail, should I be logged in as the root
or vpopmail user for all the user-mailbox administration commands?


Reply via email to