I've put in some more debugging into the esx.pm module. This should print the registration command to the screen so that it can be tried to run manually. Can you update to the latest code version and try it? I've written a how-to located here.

Best,
Brian


Brian Bouterse
Secure Open Systems Initiative
919.698.8796




On Mar 24, 2009, at 10:20 AM, Melba Lopez wrote:

Actually everything you've mentioned has been put into place.
The nameserver entry is in /etc/resolv.conf and all the esxibl1-3 hostnames
are in the /etc/hosts.
I can connect to the blades by putting esxibl1-3 into VIClient without a
problem.

Note:  /etc/resolv.conf is generated by /sbin/dhclient-script; once
network/vm is rebooted it restores original.

I also restarted the networking and went as far as to reboot the VCL VM and
still it gives me the same error.


--Melba


On Tue, Mar 24, 2009 at 9:34 AM, Brian Bouterse <bmbou...@ncsu.edu> wrote:

I'm still suspicious of your DNS resolution and configuration. In addition to creating the DNS entries in your lab's DNS server, did you connect VCL to
that DNS by creating an entry similar to the one below in the
/etc/resolv.conf on your VCL management node?

nameserver <ip_of_your_DNS_here>

Can you connect with virtual center to the blade you're trying to provision
to when referencing it strictly by it's hostname?

If you want to remove DNS resolution from the list of possible culprits, you can create an entry in /etc/hosts of your VCL management node similar to
the line below.  I think that should work.

<IP Address of esxib1>  esxibl1.

Remember to restart networking (or the whole VCL management node) when
testing these configuration changes.

Best,
Brian


Brian Bouterse
Secure Open Systems Initiative
919.698.8796




On Mar 23, 2009, at 9:13 PM, Melba Lopez wrote:

Ok, our lab already had DNS capabilities, so I've set esxibl1-3* *to be
valid hostnames*.

*However, it is still saying it can't find "esxibl1". I've pinged that hostname from another machine on the same network and it works just fine.


Also because it kept saying it couldn't load the VM, I've found another problem. The vmdk file successfully copies over into the "inuse" folder. When I manually add that VM to a blade, I'm noticing that the VM does not keep the network setings. I watched someone actually create this VM and I redid it myself, and the settings do not stay when its copied over. Not
sure if it's related, but thought I might mention it.
*


2009-03-24 04:28:57|24815|143:10|new|esx.pm:load(300)|wrote vmxarray to
/mnt/vcl/inuse/esx3-lamp-v0-bl1/esx3-lamp-v0.vmx
2009-03-24 04:28:59|24815|143:10|new|vcld:REAPER(770)|setting $? to 0,
exit
status: 0
2009-03-24 04:28:59|24815|143:10|new|esx.pm:load(321)|Registered:
|24815|143:10|new| No host found with name esxibl1.
2009-03-24 04:28:59|24815|143:10|new|esx.pm:load(330)|Power on command: /usr/lib/vmware-viperl/apps/vm/vmcontrol.pl --server 'esxibl1' -- vmname
esx3-lamp-v0-bl1 --operation poweron --username vcl --password
'd834jfhd734jgfhf7'
2009-03-24 04:29:00|24815|143:10|new|vcld:REAPER(770)|setting $? to 0,
exit
status: 0
2009-03-24 04:29:00|24815|143:10|new|esx.pm:load(333)|Powered on: Virtual
Machine esx3-lamp-v0-bl1 not found.
2009-03-24 04:29:01|24815|143:10|new|vcld:REAPER(770)|setting $? to 0,
exit
status: 0
2009-03-24 04:29:01|24815|143:10|new|vcld:REAPER(770)|setting $? to 0,
exit
status: 0
2009-03-24 04:29:01|24815|143:10|new|utils.pm:mail(1281)|SUCCESS --
Sending
mail To: r...@localhost, PROBLEM -- esx.pm

|24815|143:10|new| ---- CRITICAL ----
|24815|143:10|new| 2009-03-24 04:29:01|24815|143:10|new|esx.pm:
load(341)|Could
not query for VM in VI PERL API
|24815|143:10|new| ( 0) utils.pm, notify (line: 683)
|24815|143:10|new| (-1) esx.pm, load (line: 341)
|24815|143:10|new| (-2) new.pm, reload_image (line: 664)
|24815|143:10|new| (-3) new.pm, process (line: 266)
|24815|143:10|new| (-4) vcld, make_new_child (line: 606)
|24815|143:10|new| (-5) vcld, main (line: 353)


|24815|143:10|new| ---- WARNING ----
|24815|143:10|new| 2009-03-24
04:29:01|24815|143:10|new|new.pm:reload_image(669)|esx3-lamp-v0
failed to load on esx3-lamp-v0-bl1, returning
|24815|143:10|new| ( 0) utils.pm, notify (line: 683)*


On Thu, Mar 19, 2009 at 7:12 PM, Josh Thompson <josh_thomp...@ncsu.edu
wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thu March 19 2009 5:45:40 pm Brian Bouterse wrote:

always fake the DNS resolution by placing an entry /etc/ resolv.conf


That would be /etc/hosts  :)

Josh
- --
- -------------------------------
Josh Thompson
Systems Programmer
Virtual Computing Lab (VCL)
North Carolina State University

josh_thomp...@ncsu.edu
919-515-5323

my GPG/PGP key can be found at www.keyserver.net
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iD8DBQFJwt9xV/LQcNdtPQMRAiekAJ9Sna6on6gIZC8fO/1wKWFw9W3zIQCffxLj
nKgBCGnhdhToNQ0EtzLhRC8=
=Yjph
-----END PGP SIGNATURE-----




Reply via email to