..or maybe a better question would be:
 
After an image is created, how do you get make it available for requesting?  I 
followed these directions to create a base Windows XP image and created the 
entry in the vcl database.  
http://cwiki.apache.org/VCL/creating-a-windows-xp-base-image-on-vmware.html 
 
As stated previously, the vcld.log gives the critical error that the image 
already exists in the repository and then it goes on to say image creation 
failed and begins to exit the reservation process.
 
Is there something else that I'm supposed to do?
 


>>> "Kelly Robinson" <isg...@langate.gsu.edu> 09/28/2009 9:15 AM >>>
I am testing a base Windows XP image (no apps) and have its image requirements 
set for the following:
 
minram: 512
minprocnumber: 1
minprocspeed: 1024
minnetwork: 100
 
I've also tried to make sure the image is grouped correctly and mapped to the 
correct server, however it still gives the error.
 
Does the message in the vcld.log of "image already exists in the repository" 
after I submit the sql statements to manually place a request an image have 
anything to do with the error?
 
Thanks,
Kelly
 

>>> Nathan Dawson <ndaw...@email.wcu.edu> 09/28/2009 8:57 AM >>>

Kelly,
One other thing that it may be is if you set the image requirements too high 
(min CPU, min ram etc), if your servers or VMs aren't set high enough to meet 
those criteria it can also give you that message.

Nathan Dawson, MCP, MCDST, ACHDS
Director of Networking and Information Systems
The Kimmel School
Western Carolina University
828.227.2748

 

From:Kelly Robinson [mailto:isg...@langate.gsu.edu] 
Sent: Monday, September 28, 2009 8:50 AM
To: vcl-user@incubator.apache.org 
Subject: VCL Reservation Problem

 

How do you get VCL to allow an image to be requested?  I've added the image to 
the database and would now like to request it through the web interface, 
however when you click "New Reservation" and select the image from the drop 
down menu, it gives a message that states "Selection Not Currently Available".
 
I've tried to manually insert a request into the database using the following 
sql statements, however the vcld.log gives error messages stating that the 
image already exists in the repository.  What am I missing?
 
=================================
INSERT INTO `vcl`.`request` (
`id` ,
`stateid` ,
`userid` ,
`laststateid` ,
`logid` ,
`forimaging` ,
`test` ,
`preload` ,
`start` ,
`end` ,
`daterequested` ,
`datemodified`
)
VALUES (
'1' , '16', '1', '16', '', '1', '0', '0', NOW( ) , TIMESTAMPADD(MINUTE, 120, 
NOW()), NOW( ) , NULL
);
===============================================
 
===============================================
INSERT INTO `vcl`.`reservation` (
`id` ,
`requestid` ,
`computerid` ,
`imageid` ,
`imagerevisionid` ,
`managementnodeid` ,
`remoteIP` ,
`lastcheck` ,
`pw`
)
VALUES (
NULL , '1', '2', '7', '7', '1', NULL , NULL , NULL
);
===========================================
 
 
Thanks,
Kelly

 

 

Kelly P. Robinson 

Software Systems Engineer, Lead

Advanced Campus Services

Information Systems and Technology

P.O. Box 3994
Atlanta, Ga 30302-3994
(404) 413-4757

krobinso...@gsu.edu 

 

 

Reply via email to