-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Gerhard,

Both of these issues are ones I found on our production site but never 
remembered to check in to our code repo.  I just checked in the fix and will 
be cutting a new RC shortly and starting the vote process all over again...

The fix is to change line 130 in dashboard.php from

$txt .= "     style=\"width: 300px; height: 300px;\">\n";

to

$txt .= "     style=\"width: 300px; height: 300px; text-align: left;\">\n";

Thanks for the report,
Josh

On Wednesday March 30, 2011, Hartl, Gerhard L. wrote:
> Just a note since I figure this is somewhat related, but while the graphs
> do show properly in IE now,  the  "Past 12 Hours of Active Reservations"
> graph on the dashboard does not show within the right column table for IE
> only.  It displays outside of it instead and it gets cut in half.  Looks
> fine in Firefox.  I tried to figure out where the bug is but couldn't find
> anything obvious.
> 
> 
> - Gerhard
> Old Dominion University
> 
> -----Original Message-----
> From: Josh Thompson [mailto:josh_thomp...@ncsu.edu]
> Sent: Wednesday, March 30, 2011 12:51 PM
> To: vcl-user@incubator.apache.org
> Subject: Re: Graphs are not showing up in Internet Explorer for VCL 2.2.1
> 
> Gerhard,
> 
> There's a small bug in js/statistics.js.  You need to modify
> generateColGraphsCB and generateHourGraphsCB.  Look for graph.addAxis and
> remove the ',' after the last element in each array.  I.e. the following
> two lines
> 
> minorTickStep: majortick / 2,
> and
> minorTickStep: majortick / 5,
> 
> become
> 
> minorTickStep: majortick / 2
> and
> minorTickStep: majortick / 5
> 
> IE doesn't like commas after the last element in an array, but Firefox is
> okay with it.
> 
> I'm hoping we don't have to go through a full cycle of cutting another RC
> and doing two rounds of votes to fix the bug in the release, but I emailed
> the vcl-dev list asking our mentors what to do.
> 
> Josh
> 
> On Thursday March 24, 2011, Hartl, Gerhard L. wrote:
> > I've installed the unreleased 2.2.1 VCL and only had one issue.  I've
> > noticed that the graphs do not show up in Internet Explorer but they
> > show up fine in Firefox.  Any ideas why?  Here are the browser errors
> > I receive when displaying Statistics.
> > 
> > 
> > Webpage error details
> > 
> > User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
> > Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR
> > 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)
> > Timestamp: Thu, 24 Mar 2011 20:53:09 UTC
> > 
> > 
> > Message: Expected identifier, string or number
> > Line: 107
> > Char: 2
> > Code: 0
> > URI: https://streep.vcls.priv.odu.edu/vcl/js/statistics.js
> > 
> > 
> > Message: Object expected
> > Line: 25
> > Char: 4
> > Code: 0
> > URI: https://streep.vcls.priv.odu.edu/vcl/index.php
> > 
> > 
> > - Gerhard Hartl
> > Old Dominion University
- -- 
- -------------------------------
Josh Thompson
VCL Developer
North Carolina State University

my GPG/PGP key can be found at pgp.mit.edu
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)

iEYEARECAAYFAk2Uj5kACgkQV/LQcNdtPQPepQCdEhkjjBqO5HRu8Qq6Az1EG1EL
kOgAn35ifOh81O/1LbJPVogFIw1rv/ql
=maO+
-----END PGP SIGNATURE-----

Reply via email to