I haven't seen this before.  You could try installing/updating the
module listed in the error via the following command:
cpan Scalar::Util

-Andy

On Mon, Jul 11, 2011 at 10:33 PM, Juan Jose Zamanillo <jjzam...@itesm.mx> wrote:
> when I run the script for install  perl modules I get errors when the script
> try to install de perl-CPAN modules, and when I try to start the vcld daemon
> I get the following error:
>
> [root@labvcl ~]# /sbin/service vcld start
> Starting vcld daemon:
> Uncaught exception from user code:
>        OIO::Code error: Cannot use 'pure perl' version of Scalar::Util -
> 'weaken' missing
> Info: Upgrade/reinstall your version of Scalar::Util
> Package: VCL::DataStructure
> File: /usr/local/vcl/bin/../lib/VCL/DataStructure.pm
> Line: 79
> Compilation failed in require at
> /usr/local/vcl/bin/../lib/VCL/DataStructure.pm line 79.
> BEGIN failed--compilation aborted at
> /usr/local/vcl/bin/../lib/VCL/DataStructure.pm line 79.
> Compilation failed in require at /usr/local/vcl/bin/vcld line 62.
> BEGIN failed--compilation aborted at /usr/local/vcl/bin/vcld line 62.
> at /usr/local/vcl/bin/vcld line 62
> Use of uninitialized value in hash dereference at
> /usr/lib/perl5/site_perl/5.8.8/Object/InsideOut.pm line 891.
> Use of uninitialized value in array dereference at
> /usr/lib/perl5/site_perl/5.8.8/Object/InsideOut.pm line 990.
>                                                          [FAILED]
> thanks in Advance
>
> Regards
>

Reply via email to