Alex, 

  Thanks for your answers. How can I make sure the OS model is
os_linux_ubuntu. I don't see any option in the vcld -setup menu to choose
ubuntu. Only option for linux is generic vmware linux.

  Regarding the network, Ubuntu uses /etc/network/interfaces. After
creating ifcfg-eth0 to if cfg-eth6, will Ubuntu look for the ifcfg-eth*
for network configuration, instead of /etc/network/interfaces?

Thanks,
Lei


On 11/15/11 11:49 AM, "Alexander Patterson"
<alexander.patter...@csueastbay.edu> wrote:

>Hello,
>
>I have got Ubuntu 11.04 32 Bit* working with the VCL for our campus
>Make sure that
>OS model should be
>os_linux_ubuntu        Ubuntu Linux OS Module          
>VCL::Module::OS::Linux::Ubuntu
>The OS should be
>vmwareubuntu   Vmware Ubuntu   linux   vmware  vmware_images
>
>
>Go into your /etc/sysconfig/network-scripts/
>You should make sure that you created ifcfg-eth0 to ifcfg-eth6, hear me
>out.
>
>I have all 6 on Auto, I had noticed that sometimes a eth3 would show
>up as a eth0 or the number can be off on the adapter numbering, so it
>was easy to add more adapters that are not there but set to auto if
>they show up, the image would kick off.
>I used just this information according to
>https://cwiki.apache.org/confluence/display/VCL/Create+a+Linux+Base+Image
>
>DEVICE=eth0
>BOOTPROTO=dhcp
>ONBOOT=yes
>
>We are using DHCP, not static so it's a bit different then your setup.
>But I can let you know that it works.
>-Alex
>
>
>On Thu, Nov 10, 2011 at 11:31 PM, Huang,Lei <lhu...@pvamu.edu> wrote:
>> Dear all,
>>   I have to bother you again. I tried to create an Ubuntu image, but I
>>found
>> some problems during the base image creation. Ubuntu
>> uses /etc/network/interfaces to manage networks, but I see VCL is still
>> looking for ifcfg-eth0 and ifcfg-eth1. Another problem was unable to
>> determine the disk type, which I am not sure if it is specific to
>>Ubuntu.
>>   Does VCL support Ubuntu image?
>>
>> Thanks,
>> Lei Huang
>> ============
>> 2011-11-11
>> 
>>01:18:43|14199|856:856|image|Linux.pm:set_static_public_address(508)|atte
>>mpting
>> to set static public IP address on vmguest-1:
>> |14199|856:856|image| public interface name: eth1
>> |14199|856:856|image| public IP address: 129.207.46.17
>> |14199|856:856|image| public subnet mask: 255.255.255.0
>> |14199|856:856|image| public default gateway: 129.207.46.1
>> |14199|856:856|image| public DNS server(s): 8.8.8.8
>> 2011-11-11
>> 
>>01:18:43|14199|856:856|image|Linux.pm:set_static_public_address(514)|publ
>>ic
>> interface ifcfg file path: /etc/sysconfig/network-scripts/ifcfg-eth1
>> |14199|856:856|image| ---- WARNING ----
>> |14199|856:856|image| 2011-11-11
>> 
>>01:19:04|14199|856:856|image|Linux.pm:set_static_public_address(534)|fail
>>ed
>> to recreate /etc/sysconfig/network-scripts/ifcfg-eth1 on vmguest-1, exit
>> status: 1, command: 'echo "DEVICE=eth1
>> |14199|856:856|image| BOOTPROTO=static
>> |14199|856:856|image| IPADDR=129.207.46.17
>> |14199|856:856|image| NETMASK=255.255.255.0
>> |14199|856:856|image| STARTMODE=onboot
>> |14199|856:856|image| ONBOOT=yes
>> |14199|856:856|image| " > /etc/sysconfig/network-scripts/ifcfg-eth1',
>> output:
>> |14199|856:856|image| bash: line 6:
>> /etc/sysconfig/network-scripts/ifcfg-eth1: No such file or directory
>> |14199|856:856|image| ( 0) Linux.pm, set_static_public_address (line:
>>534)
>> |14199|856:856|image| (-1) Linux.pm, pre_capture (line: 154)
>> |14199|856:856|image| (-2) VMware.pm, capture (line: 556)
>> |14199|856:856|image| (-3) image.pm, process (line: 162)
>> |14199|856:856|image| (-4) vcld, make_new_child (line: 568)
>> |14199|856:856|image| (-5) vcld, main (line: 346)
>>
>>
>> Š..
>>
>>
>> |14199|856:856|image| ---- WARNING ----
>> |14199|856:856|image| 2011-11-11
>> 
>>01:21:58|14199|856:856|image|vmware_cmd.pm:get_virtual_disk_type(593)|una
>>ble
>> to determine disk type configured in 'vmwarelinux-ubuntuLab63-v0.vmdk',
>> command: 'grep -i createType
>> 
>>"/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63
>>-v0.vmdk"',
>> output:
>> |14199|856:856|image| Binary file
>> 
>>/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63-
>>v0.vmdk
>> matches
>> |14199|856:856|image| ( 0) vmware_cmd.pm, get_virtual_disk_type (line:
>>593)
>> |14199|856:856|image| (-1) VMware.pm, capture (line: 615)
>> |14199|856:856|image| (-2) image.pm, process (line: 162)
>> |14199|856:856|image| (-3) vcld, make_new_child (line: 568)
>> |14199|856:856|image| (-4) vcld, main (line: 346)
>> |14199|856:856|image| ---- WARNING ----
>> |14199|856:856|image| 2011-11-11
>> 01:21:58|14199|856:856|image|VMware.pm:capture(616)|failed to determine
>>the
>> virtual disk type of the vmdk being captured:
>> 
>>/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63-
>>v0.vmdk
>> |14199|856:856|image| ( 0) VMware.pm, capture (line: 616)
>> |14199|856:856|image| (-1) image.pm, process (line: 162)
>> |14199|856:856|image| (-2) vcld, make_new_child (line: 568)
>> |14199|856:856|image| (-3) vcld, main (line: 346)
>> |14199|856:856|image| ---- WARNING ----
>> |14199|856:856|image| 2011-11-11
>> 01:21:58|14199|856:856|image|VMware.pm:capture(662)|failed to find the
>>vmdk
>> files on VM host CSB302 to copy back to the managment node's image
>> repository
>> |14199|856:856|image| ( 0) VMware.pm, capture (line: 662)
>> |14199|856:856|image| (-1) image.pm, process (line: 162)
>> |14199|856:856|image| (-2) vcld, make_new_child (line: 568)
>> |14199|856:856|image| (-3) vcld, main (line: 346)
>> 2011-11-11
>> 
>>01:21:58|14199|856:856|image|Linux.pm:file_exists(1404)|'/install/vmware_
>>files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63-v0.vmdk'
>> exists on CSB302, files: 1, directories: 0, links: 0
>> 2011-11-11 01:21:58|14199|856:856|image|Linux.pm:file_exists(1390)|file
>>or
>> directory does not exist on CSB302:
>> '/install/vmware_files/Lubuntu/Lubuntu.vmdk'
>> 2011-11-11
>> 01:21:58|14199|856:856|image|VMware.pm:rename_vmdk(5026)|attempting to
>> rename vmdk:
>> 
>>'/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63
>>-v0.vmdk'
>> --> '/install/vmware_files/Lubuntu/Lubuntu.vmdk'
>> 2011-11-11
>> 01:21:59|14199|856:856|image|Linux.pm:create_directory(1524)|directory
>> already exists on CSB302: '/install/vmware_files/Lubuntu'
>> 2011-11-11
>> 
>>01:21:59|14199|856:856|image|VMware.pm:rename_vmdk(5049)|'move_virtual_di
>>sk'
>> subroutine has not been implemented by the API:
>> VCL::Module::Provisioning::VMware::vmware_cmd
>> 2011-11-11
>> 01:21:59|14199|856:856|image|VMware.pm:rename_vmdk(5056)|attempting to
>> rename vmdk file using vmware-vdiskmanager:
>> 
>>/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63-
>>v0.vmdk
>> --> /install/vmware_files/Lubuntu/Lubuntu.vmdk
>> 2011-11-11 
>>01:21:59|14199|856:856|image|VMware.pm:rename_vmdk(5063)|renamed
>> vmdk file by executing 'vmware-vdiskmanager' command on VM host:
>> |14199|856:856|image| command: vmware-vdiskmanager -n
>> 
>>"/install/vmware_files/vmwarelinux-ubuntuLab63-v0/vmwarelinux-ubuntuLab63
>>-v0.vmdk"
>> "/install/vmware_files/Lubuntu/Lubuntu.vmdk"
>> |14199|856:856|image| output: Using log file
>> /tmp/vmware-root/vdiskmanager.log
>> |14199|856:856|image| Renaming completed successfully.
>> 2011-11-11 
>>01:21:59|14199|856:856|image|VMware.pm:capture(693)|attempting to
>> delete directory where renamed vmdk resided before reverting the name
>>back
>> to the original: /install/vmware_files/vmwarelinux-ubuntuLab63-v0
>> 2011-11-11 
>>01:21:59|14199|856:856|image|Linux.pm:delete_file(1459)|deleted
>> '/install/vmware_files/vmwarelinux-ubuntuLab63-v0' on CSB302
>> 2011-11-11 01:21:59|14199|856:856|image|Linux.pm:file_exists(1390)|file
>>or
>> directory does not exist on CSB302:
>> '/install/vmware_files/vmwarelinux-ubuntuLab63-v0'
>> 2011-11-11 
>>01:21:59|14199|856:856|image|Linux.pm:delete_file(1473)|confirmed
>> file does not exist on CSB302:
>> '/install/vmware_files/vmwarelinux-ubuntuLab63-v0'
>> 2011-11-11 
>>01:21:59|14199|856:856|image|VMware.pm:capture(699)|attempting to
>> power the VM back on so that it can be captured again
>> 2011-11-11
>> 01:22:00|14199|856:856|image|vmware_cmd.pm:vm_power_on(300)|powered on
>>VM:
>> 'Lubuntu.vmx'
>> |14199|856:856|image| ---- WARNING ----
>> |14199|856:856|image| 2011-11-11
>> 
>>01:22:00|14199|856:856|image|image.pm:process(166)|vmwarelinux-ubuntuLab6
>>3-v0
>> image failed to be captured by provisioning module
>> |14199|856:856|image| ( 0) image.pm, process (line: 166)
>> |14199|856:856|image| (-1) vcld, make_new_child (line: 568)
>> |14199|856:856|image| (-2) vcld, main (line: 346)
>>
>
>
>
>-- 
>Thanks,
>Alex  Patterson
>User Support Services
>Operating System Analyst
>California State University, East Bay

Reply via email to