Up to this point, I have been following the documentation exactly, so I have configured the machine to use SSH and I have configured the VMhost using the second link below. Since your suggestion, I am attempting to work with the vsphere SDK. I am having trouble with some of the dependencies getting installed, but I feel that they will be finished soon. Is there any documentation on incorporating the VSphere SDK into the VCL Server?

Aaron Bryant


On 3/16/2012 3:02 PM, Aaron Coburn wrote:
Given that your VMhost is called "vsphere", is it safe to assume
that you plan to use the vSphere API to access the host?

If that is the case, you need to make sure that the vSphere SDK
for perl is installed. According to your logfile, the perl libraries are
either not installed or not in perl's path (i.e. @INC).

If you intend to use the perl SDK, you can install it from here:

http://www.vmware.com/support/developer/viperltoolkit/

(be sure to select the release corresponding to your VMware version)

If you are not going to use the vSphere API, then make sure to
read through this page as you configure your VMhost:

https://cwiki.apache.org/confluence/display/VCL/VMware+Configuration


Aaron

--
Aaron Coburn
Systems Administrator and Programmer
Academic Technology Services, Amherst College
(413) 542-5451 acob...@amherst.edu


On Mar 16, 2012, at 1:13 PM, Aaron Bryant wrote:

After seeing your suggestion, I have done the following changes to no avail:

- Disabled Selinux
- Changed the syntax of the hosts file from IP Address - Alias - Hostname, to 
IP Address - Hostname - Alias (Just to make sure this wasn't causing a problem)

I can't seem to find any problems with permissions.  I also could not find any valid reason for the 
"cat" to fail, although directly after it fails, it prints the output of the 
"cat" command in the log file.

The problem is still occurring even after the simple changes I have made.  Any 
additional suggestions?



On 2/28/2012 4:21 PM, Dmitri Chebotarov wrote:
Aaron

The problem seems to be with your /etc/hosts file.
'cat /etc/hosts' failed with exit status 255, when exit status 0 is expected. 
B/c of this, vcl couldn't get private ip address and didn't attempt to connect 
to the host. I cannot think of any valid reasons why 'cat /etc/hosts' would 
fail... Can you double-check syntax, permission, selinux, ... ?

...
|10951|20:20|image| ---- WARNING ----
|10951|20:20|image| 2012-02-28 
13:32:34|10951|20:20|image|DataStructure.pm:get_computer_private_ip_address(1589)|failed
 to cat /etc/hosts on this management node, exit status: 255, output:
|10951|20:20|image| 127.0.0.1 localhost localhost.localdomain localhost4 
localhost4.localdomain4
|10951|20:20|image| 192.168.0.101 1vsphere 1vsphere.upb.pitt.edu
...
On Feb 28, 2012, at 13:28 , Aaron Bryant wrote:

Greetings,

I completed installing Cygwin SSHD and I'm attempting to run the vcld -setup 
command.  My problem occurs in this step while creating a base image.  I am 
able to get through all of the prompts and start the creation before the script 
crashes.  I have checked the '/var/log/vcld.log' log file and this is a portion 
of the output:

-------------------------------------------------------------------------------------------------------
VCL::Module::Provisioning::VMware::vSphere_SDK

|10951|20:20|image| ---- WARNING ----
|10951|20:20|image| 2012-02-28

13:32:34|10951|20:20|image|VMware.pm:initialize(273)|no methods are available 
to control VM host vsphere, the

vSphere SDK cannot be used to control the VM host and the host OS cannot be 
controlled via SSH
|10951|20:20|image| (

0) VMware.pm, initialize (line: 273)
|10951|20:20|image| (-1) Module.pm, new (line: 207)
|10951|20:20|image| (-2)

Module.pm, create_provisioning_object (line: 423)
|10951|20:20|image| (-3) State.pm, initialize (line: 117)
|10951|

20:20|image| (-4) Module.pm, new (line: 207)
|10951|20:20|image| (-5) vcld, make_new_child (line: 564)


|10951|20:20|

image| ---- WARNING ----
|10951|20:20|image| 2012-02-28 13:32:34|10951|20:20|image|

Module.pm:create_provisioning_object(431)|provisioning object could not be 
created, returning 0
|10951|20:20|image|

( 0) Module.pm, create_provisioning_object (line: 431)
|10951|20:20|image| (-1) State.pm, initialize (line: 117)
|

10951|20:20|image| (-2) Module.pm, new (line: 207)
|10951|20:20|image| (-3) vcld, make_new_child (line: 564)
|10951|
---------------------------------------------------------------------------------------------


I have checked and am able to ssh between the management node and the virtual 
machines using key authentication.

Please see the log file attached for more information.

Thanks,
Aaron Bryant
<Logfile.txt>


Thank you.

-----------------
Dmitri Chebotarov
dcheb...@gmu.edu
703-993-6175
-----------------


<Logfile.txt>

Reply via email to