I have been using vde and qemu for a long while to connect multiple qemu guest 
OSes together, I am finding it extremely useful to testing out certain 
networking features. They have been working fine without any problem. This is a 
example of set up of mine :-

for i in 1 2 3 4 5
    vde_switch -sock /tmp/vde.ctl${i} -tap tap${i} -daemon

Example of a guest OS 1 using qemu :-

qemu-system-x86_64 \
-net nic,model=rtl8139,vlan=0,macaddr=12:34:56:78:90:ac \
-m 128 -boot c -hda guest.lan.img \
-enable-kvm \
-net vde,vlan=0,sock=/tmp/vde.ctl1

Guest OS 2 :-
qemu-system-x86_64 \
-net nic,model=rtl8139,vlan=0,macaddr=00:00:00:00:00:88 \
-net nic,model=rtl8139,vlan=1,macaddr=00:00:00:00:00:89 \
-net vde,vlan=0,sock=/tmp/vde.ctl1 \
-net vde,vlan=1,sock=/tmp/vde.ctl2 \
-enable-kvm \
-m 96 -boot c -hda guest.nat.img

In this example, guest OS 1 eth0 will then be connected to guest OS 2 eth0. 
Pinging each other without problem.

However if I setup VLAN in guest OS 1 and VLAN in guest OS 2, they can't ping 
each other :-

Guest OS 1:-
    # vconfig add eth0 150
    # ifconfig eth0.150 up
Guess OS 2:-
    # vconfig add eth0 150
    # ifconfig eth0.150 up

I can't ping each other.

I tried changing vde_switch adding '-hub' flag, it did not make any difference. 

What am I doing wrong ? Has anyone tried this kind of configuration before ? 


Enable your software for Intel(R) Active Management Technology to meet the
growing manageability and security demands of your customers. Businesses
are taking advantage of Intel(R) vPro (TM) technology - will your software 
be a part of the solution? Download the Intel(R) Manageability Checker 
today! http://p.sf.net/sfu/intel-dev2devmar
vde-users mailing list

Reply via email to