I'm happily using vde/qemu now for years on debian/unbutu and had never 
any problems, apart from having to compile qemu myself for vde support, 
which always worked fine.

I now tried to put together a system with qemu 2.2.0 and vde2 2.3.2 and 
while vde seems to run ok, the qemu vm cannot communicate with the vde 
network. qemu 2.2.0 self-compiled against libvdeplug 2.2.3 and running 
vde2 2.2.3 from Ubuntu works runs fine.

I have setup my vde_switch as follows:

modprobe kvm-intel
chgrp adm /dev/kvm
chmod g+rw /dev/kvm
echo "1024" > /proc/sys/dev/hpet/max-user-freq
modprobe tun
vde_switch -tap tap0 --pidfile /var/run/qemu-vde_switch.pid -daemon
chmod -R a+rwx /var/run/vde.ctl
ifconfig tap0 broadcast netmask up
echo "1" > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
dnsmasq --log-queries --user=dnsmasq \
   --dhcp-leasefile=/var/lib/misc/qemu-dhcpd.leases \
   --dhcp-range=,,,,8h \
   --interface=tap0 \
   --domain=decentral.ch \

The vde_switch runs ok, I guess, I can ping and do an

nslookup www.google.com

with good results.

I have compiled qemu with vde support (--enable-vde), the binary also 
links against vde:

ldd /usr/bin/qemu-system-x86_64
        linux-vdso.so.1 (0x00007fffc05f5000)
        libz.so.1 => /lib/libz.so.1 (0x00007f23ca87e000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f23ca62d000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007f23ca42c000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f23ca121000)
        librt.so.1 => /lib/librt.so.1 (0x00007f23c9f19000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f23c9c6f000)
        libutil.so.1 => /lib/libutil.so.1 (0x00007f23c9a6c000)
        libncursesw.so.5 => /lib/libncursesw.so.5 (0x00007f23c9808000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f23c94e3000)
        libvdeplug.so.3 => /usr/lib/libvdeplug.so.3 (0x00007f23c92de000)

I start the quest vm with parameters:

/usr/bin/qemu-system-x86_64 -enable-kvm -m 1024 -boot c -hda sda -cdrom 
gaiarise-vga.iso -net nic,macaddr=52:54:00:12:34:84 -net vde -vnc -k de-ch -vga std

The network card comes up in the qemu guest vm, but neither 
communication with dhcp nor a fixed ip works. The host system is running 
kernel 3.19.1, the guest also something like that although the guest is 
definitely not the problem, as the same guest runs fine on my ubuntu 
system with vde 2.2.3.

When the vm starts, I get a

ls -l /var/run/vde.ctl/*
srwx------ 1 timtas root 0 Mar 11 10:58 /var/run/vde.ctl/002.7
srwxrwxrwx 1 root   root 0 Mar 11 10:58 /var/run/vde.ctl/ctl

so, it seems that some connection to the switch is made. On my ubuntu, 
the files however look a bit different:
ls -l /var/run/vde.ctl/*
srwx------ 1 qemu root 0 Mar  2 18:46 /var/run/vde.ctl/002
srwxrwxrwx 1 root root 0 Aug  8  2014 /var/run/vde.ctl/ctl

Is there something else I have to do to make this work, maybe dowgrade 
to 2.2.3 or do I have to set some kernel parameters on the host system?

I also tried svn (r587), with the exact same results, btw.

Kind regards

Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the 
conversation now. http://goparallel.sourceforge.net/
vde-users mailing list

Reply via email to