On 1/10/07, mike lewis <[EMAIL PROTECTED]> wrote:
On 1/10/07, mike lewis <[EMAIL PROTECTED]> wrote:
> On 12/21/06, Darren Salt <[EMAIL PROTECTED]> wrote:
> > I demand that mike lewis may or may not have written...
> >
> > [snip]
> > > OK.  I tried to install xine last night.  I have some rather complex
> > > dependancy problems.  I'm using all ubunuto apt-get servers and then your
> > > apt-get server.  Basically, the packages on your site depend on versions 
of
> > > software that ubuntu doesn't see to supply. [...]
> >
> > Hmm. My 'stable' builds are for too old a distribution, and it looks very
> > much like my 'testing' builds are for one which is just that little bit too
> > new...
> >
> > > Soo. Yes.  I'm guessing there are some other "bleeding edge" software
> > > repositories that I need to enable as well??
> >
> > No. Your problem is that you're (presumably) using edgy whereas I build for
> > sarge (too old), etch (slightly too new) and unstable (also slightly too
> > new), and I currently have no plans to build for Ubuntu releases.
> >
> > Given this, I think that it's best that you add a deb-src line for my
> > archive, run 'aptitude update', install devscripts and build-essential, 
then:
> >
> >   $ apt-get source foo
> >   $ cd foo-*
> >   $ sudo apt-get build-dep foo
> >   $ debuild binary
> >
> >   $ sudo dpkg -i ../*.deb
> >
> > Be careful with that last line - you'll probably want to list specific
> > package files. And dependency errors shouldn't be a problem either since you
> > can use aptitude to install the missing packages and mark them as
> > automatically installed.
> >
> I finally got around to trying this.  Stuck at "debuild".  I'm unable
> to find it on my system and unable to find it as a refference in
> aptitude (hitting S in the GUI).
>
> Trying debian-builder as the closest match ;-)
>
Yep, that was it!

OK, err, well.. It was one part of it.  Now, I can't run that
script...  I've tried sudo and no sudo and I get different errors in
either method.

[EMAIL PROTECTED]:/build/newxine/xine-lib-vdr-1.1.3$ debuild binary
/usr/bin/fakeroot: 152: debian/rules: Permission denied
debuild: fatal error at line 1206:
couldn't exec fakeroot debian/rules:
[EMAIL PROTECTED]:/build/newxine/xine-lib-vdr-1.1.3$ sudo debuild binary
Can't exec "debian/rules": Permission denied at /usr/bin/debuild line 1201.
debuild: fatal error at line 1200:
couldn't exec debian/rules: Permission denied

Line 152 appears to be a simple "echo" command to blit the scripts
version to the screen.  So something about my permissions must be very
broken.  I've tried su as well and I get the same error as sudo.

What the?  This newbie is dumbfounded..

Mick

_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to