I'm running patched xine-lib on a Gentoo system,
media-libs/xine-lib-1.1.8with the vdr USE flag.

vdr-1.5.8 using vdr-xine-0.7.11 as the software output device. I'm having
problems with the editing of recordings when setting a marker, also with
fast rewinding and fast forward, pause + forward/rewind.

With fast forward it will jump 15sec forward from the start and when going
back to normal play/pause, it will rewind 10 sec, making the forward
unpredictable. The same goes for rewind. It is 15sec in reverse ahead also,
and jumps a few seconds forward when going back to normal play.

In pause + rewind the following is happening:
Example 1:
I pause at e.g. 1:35:32, pressing rewind will jump to 1:35:18 and stop at
1:34:50 when I immediately tried to pause again. When I press play, it will
jump to 1:35:06. This jumping makes it very uncomfortable to use the

Only pause + forward works as expected.

Example 2:

I will start playing at 1:35:07, and press forward and later on press the
play button again at 1:35:55, but video will move back to 1:35:50

Example 3:

I will start playing at 1:35:55 and it will rewind to 1:35:12, on pressing
the play button again it will jump to 1:35:29 (appears to be the same
problem as with pause + rewind)

Example 4:
The video has come to an end at 2:11:08, but it will play on for a further 5
seconds, when the timer is not counting anymore.

Example 5:
I will pause the video at 1:35:55 and press the marker button, the marker
says at 1:35:55.2 but when I press play, it will jump to 1:36:00

The same strange behavior happens with the vdr-softdevice-0.4 (the change in
time is a bit different but still the same strange behavior) It was more or
less working in vdr-1.5.5. I only have a budget card in my machine. Reinhard
Ni├čl from vdr-xine suggested it is a buffer problem between vdr and the
software device plug-in.

Your assistance would be appreciated.

vdr mailing list

Reply via email to