I have here the problem that vdr 1.5.10 will not run anymore. So I
tried to debug it but I had problems with it.
I ran it with gdb vdr
then inserted run
I got:
Starting program: /usr/local/video/vdr-1.5.10/vdr 
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread -1213470528 (LWP 5278)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1213470528 (LWP 5278)]
0x0bf3d086 in ?? ()

I tried now a backtrace but I only got:
#0  0x0bf3d086 in ?? ()
#1  0xb7a6c657 in gconv () from /usr/lib/gconv/ISO8859-2.so
#2  0xb7c01c11 in ?? () from /lib/libc.so.6
#3  0x08194cc0 in ?? ()
#4  0x081950c8 in ?? ()
#5  0xbfd006ec in ?? ()
#6  0xb7a73305 in ?? ()
#7  0x00000000 in ?? ()

I compiled VDR with:
CFLAGS   = -g -O0
CXXFLAGS = -g -fPIC -O0 -Wall -Woverloaded-virtual
in Make.config.

What can I do here to trace the error?

Best regards,


"Programming today is a race between software engineers striving to
build bigger and better idiot-proof programs, and the universe trying to
produce bigger and better idiots. So far, the universe is winning." --
Rich Cook

vdr mailing list

Reply via email to