I tried starting vdr without existing setup.conf and by default it seems
that Sans Serif is used. But it seems that I don't have that either since
Vdr still segfaults, now with following backtrace. By the way, is "fc-list"
the correct way to check if certain font is available or not? According to
fc-list I don't have Sans Serif..

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1211853120 (LWP 11533)]
0xb7ebe2f6 in FcCharSetCoverage () from /usr/lib/libfontconfig.so.1
(gdb) bt
#0  0xb7ebe2f6 in FcCharSetCoverage () from /usr/lib/libfontconfig.so.1
#1  0xb7ebe837 in FcNameParseCharSet () from /usr/lib/libfontconfig.so.1
#2  0xb7ec74c1 in FcNameParse () from /usr/lib/libfontconfig.so.1
#3  0xb7eb8660 in FcBlanksIsMember () from /usr/lib/libfontconfig.so.1
#4  0xb7eba52e in FcDirCacheReadDir () from /usr/lib/libfontconfig.so.1
#5  0xb7ec00c0 in FcDirScanConfig () from /usr/lib/libfontconfig.so.1
#6  0xb7ebaa47 in FcConfigBuildFonts () from /usr/lib/libfontconfig.so.1
#7  0xb7ec3413 in FcInitLoadConfigAndFonts () from
#8  0xb7ec3638 in FcInit () from /usr/lib/libfontconfig.so.1
#9  0x080b37cf in cFont::GetFontFileName (FontName=0x815297c "Sans Serif")
at font.c:392
#10 0x080b4e59 in cFont::CreateFont (Name=0x8 <Address>, CharHeight=8,
CharWidth=8) at font.c:337
#11 0x080b4ef5 in cFont::SetFont (Font=fontSml, Name=0x8 <Address>,
CharHeight=8) at font.c:312
#12 0x080b4fcb in cFont::GetFont (Font=fontSml) at font.c:328
#13 0x080fc3ca in cSkinSTTNGDisplayMenu (this=0x8518268) at skinsttng.c:386
#14 0x080fcab2 in cSkinSTTNG::DisplayMenu (this=0x8515f60) at skinsttng.c:1146

#15 0x080b7348 in cInterface::LearnKeys (this=0x8515f28) at interface.c:165
#16 0x0810e8fb in main (argc=8, argv=0xbffad7e4) at vdr.c:662


2007/11/9, Lauri Tischler <[EMAIL PROTECTED]>:
> Mika Orajärvi wrote:
> > Hi!
> >
> > I'm trying to update vdr 1.4.x to 1.5.11. But my vdr keeps segfaulting
> every
> > time when it's started. It takes about 2-3 s after starting the vdr to
> the
> > segfault. I've tried running it only with xine-plugin (0.8.0) so far and
> > without any patches on top of vdr. And i'm running vdr on Ubuntu Dapper.
> >
> > GDB gives following backtrace, any ideas? It seems to be something
> related
> > to fonts,.. but beyond that I have no idea.
> VDR does crash if you dont have selected font available.
> I can crash my 1.5.11 everytime when in OSD I select font
> which I dont have, I tryed with 'small font'.
> Then I need to manually edit 'FontSml' to existing font,
> Sans Serif.
> _______________________________________________
> vdr mailing list
> vdr@linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
vdr mailing list

Reply via email to