After almost a year without TV (the old VDR box died completely and we didn't 
bother to rebuild it) it's time to watch some Christmas specials and I've 
tried to resurrect VDR.

I have it all working ok for our FTA cable channels and VDR works as it should 
there. For the few subscription channels we have a Hauppauge CI and a Conax 
CAM and a normal "subscription card". This setup worked well for years before 
the crash to I assume it should work ok now too.

During startup I see:

CAM 4: module ready
CAM 4: Conax 4.00e, 01, 0B00, 04B1
CAM 4: doesn't reply to QUERY - only a single channel can be decrypted

Which looks ok to me. Then I also see a few of these pairs:

CAM 4: module reset
CAM 4: module present

Looking into the Setup->CAM menu shows that "CAM 4" is present and is a Conax 
4.00. Sometimes I can open the menu for the CAM but usually it fails. When it 
happens to open and I choose anything from the five entries there nothing 
ever happens, for some options I see some "Please wait" text and then after a 
while the menu is closed. So, something isn't right there.

After fiddling with the CA descriptor in channels.conf (this isn't really that 
much documented) I manage to get this:

CAM 4: unassigned
skipped channels 15..19

The channels 15 to 19 are the encrypted channels. The initial channels.conf I 
got from "scan" had "1" for the CA field, but reading this:


I see the quote:

"Please set the CA parameter of these channels to 0 (FTA) and tune to them 
again. VDR should automatically insert the correct CA values then."

So I set them to "0" and restarted VDR. Now I see that VDR has changed the 
entries to:


ie "B00". Could be ok as this seems to be the id of the CAM. Hardcoding "4" 
there has no effect, and "1" at least makes VDR take a bit longer to decide 
that "Channel not available".

I am not trying to record multiple channels or do anything fancy, just get VDR 
limping along so that we can watch some live TV the next few days.

The setup is:

        * 2 Hauppauge DVB-c FF cards
        * Hauppauge CI
        * Conax 4.x CAM
        * vdr-1.5.9 (unpatched)

I'll do a test with 1.4.7 too, just to make sure. Hang on! Nah, same thing 
with 1.4.7.

Any ideas what could cause this?

Best regards and a Merry Christmas,

        Jan Ekholm

  "You can't trample infidels when you're a tortoise. I mean, all you could
                  do is give them a meaningful look."
                                              -- Terry Pratchett, Small Gods

vdr mailing list

Reply via email to