I'm using vdr 1.4.7 and mplayer plugin from e-tobi on Debian Etch with a
full featured Hauppauge Nexus-S card and having trouble with audio 
during video playback.

When I configure mplayer to decode audio with the Nexus by setting


in /etc/vdr/plugins/vdrmplayer.sh.conf, movie playback doesn't work at 
all. I get a black screen, TV audio mutes but movie playback doesn't 
start. The mplayer process is there, but seems to do nothing:

  /usr/bin/mplayer -vo mpegpes:card=1 -ao mpegpes:card=1 \
       -vf scale=704:331,expand=704:576:-1:-1:1,lavc=5000:25 \
       -framedrop -cache-min 10 -slave -nolirc -subpos 80 \
       -sub-bg-color 0 -sub-bg-alpha 30 -quiet -osdlevel 0 \

When I press "Exit" (a few times) on my remote, vdr resumes to TV 
playback, but often I need to restart vdr for proper operation. 
Otherwise I can't tune all channels resp. I'm getting messages of 
channels not available.

I stopped vdr and tried the command line above (only removed -slave 
option): this works pretty well. I get proper video and audio playback.
For me it seems, that vdr still occupies the DVB (audio) device when the
plugin starts mplayer for video playback. Is that possible?

I tried playing audio via the onboard soundchip by setting


and this works so far. But audio and video are getting seriously out of
sync, so this is no reasonable workaround for the problem (besides that
switching my amplifier to the other audio line is somewhat annoying ;)

Something I'm doing wrong?

Any help is appreciated. If you need more configuration information 
please ask for it.



sub i($){print$_[0]}*j=*ENV;sub w($){sleep$_[0]}sub _($){i"$p:$c> ",w+01
,$_=$_[0],tr;i-za-h,;a-hi-z ;,i$_,w+01,i"\n"}$|=1;$f='HO';($c=$j{PWD})=~
"-zn,*",_"#,epg,lw,gwc,mfmkcbm,cvsvwev,uiqt,kwvbmvb?",i"$p:$c> ";w+1<<07

Attachment: pgphTbSU9trfq.pgp
Description: PGP signature

vdr mailing list

Reply via email to