Hallo Reinhard,

which revision of external ffmpeg do you use? I can't compile
xine-lib-cvs-20080310200000 + your patch with last ffmpeg revisions.
In file included from ffmpeg_decoder.h:31,
                 from ffmpeg_decoder.c:30:
./libavcodec/avcodec.h:34:20: error: avutil.h: No such file or directory
In file included from ffmpeg_decoder.h:31,
                 from ffmpeg_decoder.c:30:
./libavcodec/avcodec.h:716: error: expected specifier-qualifier-list
before 'AVClass'
./libavcodec/avcodec.h:2098: error: expected ':', ',', ';', '}' or
'__attribute__' before '*' token
./libavcodec/avcodec.h:2131: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'attribute_deprecated'
./libavcodec/avcodec.h:2524: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'int'

Last checkout from xine-lib-1.2 does works. But your
xine/patches/xine-lib.patch has many rejects and reverts with this
tree.

Regards
Oleg

_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to